summaryrefslogtreecommitdiffstats
path: root/meta/packages/apr/apr-util_1.3.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-07 17:22:15 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-07 17:22:15 +0000
commiteb72830fcf40b195e72fad06ca7e470565c21d8b (patch)
treeee5292f0881ff0e5cd700b22392a43cac27e722c /meta/packages/apr/apr-util_1.3.4.bb
parent30238161a6ad7bb6f7a91d589567e1dd5b0196c7 (diff)
downloadpoky-eb72830fcf40b195e72fad06ca7e470565c21d8b.tar.gz
Add apr, apt-util and subversion based on recipes from OE with tweaks from Josh/me
Diffstat (limited to 'meta/packages/apr/apr-util_1.3.4.bb')
-rw-r--r--meta/packages/apr/apr-util_1.3.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/packages/apr/apr-util_1.3.4.bb b/meta/packages/apr/apr-util_1.3.4.bb
new file mode 100644
index 0000000000..590c22e882
--- /dev/null
+++ b/meta/packages/apr/apr-util_1.3.4.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2SECTION = "libs"
3DEPENDS = "apr expat gdbm"
4LICENSE = "Apache License, Version 2.0"
5
6PR = "r2"
7
8SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
9 file://configure_fixes.patch;patch=1"
10
11EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
12 --with-dbm=gdbm \
13 --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
14 --without-sqlite2 \
15 --without-sqlite3 \
16 --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
17
18
19inherit autotools_stage lib_package binconfig
20
21OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
22
23do_configure_prepend() {
24 cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
25}
26