summaryrefslogtreecommitdiffstats
path: root/meta/packages/apmd/apmd_3.2.2.bb
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-07-13 16:46:46 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 21:44:37 +0100
commit75fff516610b8f8b64523979c005fddd4ec4a76d (patch)
treed8378a8f01b3580c66f42f3609e45a63d13b7224 /meta/packages/apmd/apmd_3.2.2.bb
parentcb249ed2f0791d021593209cd000baaa9629fcf1 (diff)
downloadpoky-75fff516610b8f8b64523979c005fddd4ec4a76d.tar.gz
apmd: upgrade to 3.2.2-14
[Patches] KEEP _unlinux.patch_: remove reference to build system paths DISABLE _libtool.patch_: this patch adds a "--tag=CC" to be compatible with libtool2.2.4. however with latest 2.2.10 libtool, w/o this patch it still works. From the manual, CC is the default tag actually. So disable it for now, and once same error happens again, it'll be re-neabled and if necessary push to upstream DISABLE _workaround.patch_: a SIGUSR1 is hooked to signal suspend event as a so-called 'workaround'. however no exact commit is found for exact usage case. So disable it. REMOVE _debian.patch_: in upstream [Recipe] Add license checksum Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/apmd/apmd_3.2.2.bb')
-rw-r--r--meta/packages/apmd/apmd_3.2.2.bb61
1 files changed, 0 insertions, 61 deletions
diff --git a/meta/packages/apmd/apmd_3.2.2.bb b/meta/packages/apmd/apmd_3.2.2.bb
deleted file mode 100644
index 821f0855f9..0000000000
--- a/meta/packages/apmd/apmd_3.2.2.bb
+++ /dev/null
@@ -1,61 +0,0 @@
1DESCRIPTION = "Set of tools for managing notebook power consumption."
2SECTION = "base"
3PRIORITY = "required"
4LICENSE = "GPLv2+"
5DEPENDS = "libtool-cross"
6PR = "r13"
7
8SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.orig.tar.gz \
9 file://debian.patch \
10 file://workaround.patch \
11 file://unlinux.patch \
12 file://libtool.patch \
13 file://init \
14 file://default \
15 file://apmd_proxy \
16 file://apmd_proxy.conf"
17
18S = "${WORKDIR}/apmd-${PV}.orig"
19
20inherit update-rc.d
21
22INITSCRIPT_NAME = "apmd"
23INITSCRIPT_PARAMS = "defaults"
24
25do_compile() {
26 oe_runmake "LIBTOOL=${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool" apm apmd
27}
28
29do_install() {
30 install -d ${D}${sysconfdir}
31 install -d ${D}${sysconfdir}/apm
32 install -d ${D}${sysconfdir}/apm/event.d
33 install -d ${D}${sysconfdir}/apm/other.d
34 install -d ${D}${sysconfdir}/apm/suspend.d
35 install -d ${D}${sysconfdir}/apm/resume.d
36 install -d ${D}${sysconfdir}/apm/scripts.d
37 install -d ${D}${sysconfdir}/default
38 install -d ${D}${sysconfdir}/init.d
39 install -d ${D}${sbindir}
40 install -d ${D}${bindir}
41 install -d ${D}${libdir}
42 install -d ${D}${datadir}/apmd
43 install -d ${D}${includedir}
44
45 install -m 4755 ${S}/.libs/apm ${D}${bindir}/apm
46 install -m 0755 ${S}/.libs/apmd ${D}${sbindir}/apmd
47 install -m 0755 ${WORKDIR}/apmd_proxy ${D}${sysconfdir}/apm/
48 install -m 0644 ${WORKDIR}/apmd_proxy.conf ${D}${datadir}/apmd/
49 install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/apmd
50 oe_libinstall -so libapm ${D}${libdir}
51 install -m 0644 apm.h ${D}${includedir}
52
53 cat ${WORKDIR}/init | sed -e 's,/usr/sbin,${sbindir},g; s,/etc,${sysconfdir},g;' > ${D}${sysconfdir}/init.d/apmd
54 chmod 755 ${D}${sysconfdir}/init.d/apmd
55}
56
57PACKAGES =+ "libapm libapm-dev apm"
58
59FILES_libapm = "${libdir}/libapm.so.*"
60FILES_libapm-dev = "${libdir}/libapm.* ${includedir}"
61FILES_apm = "${bindir}/apm*"