diff options
author | Kevin Tian <kevin.tian@intel.com> | 2010-07-13 16:46:46 +0800 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-07-21 21:44:37 +0100 |
commit | 75fff516610b8f8b64523979c005fddd4ec4a76d (patch) | |
tree | d8378a8f01b3580c66f42f3609e45a63d13b7224 /meta/packages/apmd/apmd_3.2.2-14.bb | |
parent | cb249ed2f0791d021593209cd000baaa9629fcf1 (diff) | |
download | poky-75fff516610b8f8b64523979c005fddd4ec4a76d.tar.gz |
apmd: upgrade to 3.2.2-14
[Patches]
KEEP _unlinux.patch_: remove reference to build system paths
DISABLE _libtool.patch_: this patch adds a "--tag=CC" to be compatible with libtool2.2.4.
however with latest 2.2.10 libtool, w/o this patch it still works. From
the manual, CC is the default tag actually. So disable it for now, and once
same error happens again, it'll be re-neabled and if necessary push to upstream
DISABLE _workaround.patch_: a SIGUSR1 is hooked to signal suspend event as a so-called 'workaround'.
however no exact commit is found for exact usage case. So disable it.
REMOVE _debian.patch_: in upstream
[Recipe]
Add license checksum
Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/apmd/apmd_3.2.2-14.bb')
-rw-r--r-- | meta/packages/apmd/apmd_3.2.2-14.bb | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/packages/apmd/apmd_3.2.2-14.bb b/meta/packages/apmd/apmd_3.2.2-14.bb new file mode 100644 index 0000000000..70d07c3561 --- /dev/null +++ b/meta/packages/apmd/apmd_3.2.2-14.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | DESCRIPTION = "Set of tools for managing notebook power consumption." | ||
2 | SECTION = "base" | ||
3 | PRIORITY = "required" | ||
4 | LICENSE = "GPLv2+" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
6 | file://apm.h;firstline=6;endline=18;md5=c9a1f79036ab14aa157e15ed75ffd769" | ||
7 | DEPENDS = "libtool-cross" | ||
8 | PR = "r0" | ||
9 | |||
10 | SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_3.2.2.orig.tar.gz \ | ||
11 | ${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.diff.gz \ | ||
12 | file://unlinux.patch \ | ||
13 | file://init \ | ||
14 | file://default \ | ||
15 | file://apmd_proxy \ | ||
16 | file://apmd_proxy.conf" | ||
17 | |||
18 | S = "${WORKDIR}/apmd-3.2.2.orig" | ||
19 | |||
20 | inherit update-rc.d | ||
21 | |||
22 | INITSCRIPT_NAME = "apmd" | ||
23 | INITSCRIPT_PARAMS = "defaults" | ||
24 | |||
25 | do_compile() { | ||
26 | # apmd doesn't use whole autotools. Just libtool for installation | ||
27 | oe_runmake "LIBTOOL=${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool" apm apmd | ||
28 | } | ||
29 | |||
30 | do_install() { | ||
31 | install -d ${D}${sysconfdir} | ||
32 | install -d ${D}${sysconfdir}/apm | ||
33 | install -d ${D}${sysconfdir}/apm/event.d | ||
34 | install -d ${D}${sysconfdir}/apm/other.d | ||
35 | install -d ${D}${sysconfdir}/apm/suspend.d | ||
36 | install -d ${D}${sysconfdir}/apm/resume.d | ||
37 | install -d ${D}${sysconfdir}/apm/scripts.d | ||
38 | install -d ${D}${sysconfdir}/default | ||
39 | install -d ${D}${sysconfdir}/init.d | ||
40 | install -d ${D}${sbindir} | ||
41 | install -d ${D}${bindir} | ||
42 | install -d ${D}${libdir} | ||
43 | install -d ${D}${datadir}/apmd | ||
44 | install -d ${D}${includedir} | ||
45 | |||
46 | install -m 4755 ${S}/.libs/apm ${D}${bindir}/apm | ||
47 | install -m 0755 ${S}/.libs/apmd ${D}${sbindir}/apmd | ||
48 | install -m 0755 ${WORKDIR}/apmd_proxy ${D}${sysconfdir}/apm/ | ||
49 | install -m 0644 ${WORKDIR}/apmd_proxy.conf ${D}${datadir}/apmd/ | ||
50 | install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/apmd | ||
51 | oe_libinstall -so libapm ${D}${libdir} | ||
52 | install -m 0644 apm.h ${D}${includedir} | ||
53 | |||
54 | cat ${WORKDIR}/init | sed -e 's,/usr/sbin,${sbindir},g; s,/etc,${sysconfdir},g;' > ${D}${sysconfdir}/init.d/apmd | ||
55 | chmod 755 ${D}${sysconfdir}/init.d/apmd | ||
56 | } | ||
57 | |||
58 | PACKAGES =+ "libapm libapm-dev apm" | ||
59 | |||
60 | FILES_libapm = "${libdir}/libapm.so.*" | ||
61 | FILES_libapm-dev = "${libdir}/libapm.* ${includedir}" | ||
62 | FILES_apm = "${bindir}/apm*" | ||