summaryrefslogtreecommitdiffstats
path: root/meta/packages/abiword
diff options
context:
space:
mode:
authorTomas Frydrych <tf@openedhand.com>2007-01-12 21:26:44 +0000
committerTomas Frydrych <tf@openedhand.com>2007-01-12 21:26:44 +0000
commit2eebb483924654661dbf2429a8434d14afac55a9 (patch)
tree880e1e5e6526925a03551577470e67b76c7f7e50 /meta/packages/abiword
parent81c9ad8b0f826c1aab3ebe1eff6ccb88141bf0ad (diff)
downloadpoky-2eebb483924654661dbf2429a8434d14afac55a9.tar.gz
add recipes for packages needed to build AbiWord (based on OE, but tweaked for 2.5.x)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1140 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/abiword')
-rw-r--r--meta/packages/abiword/abiword.inc63
-rw-r--r--meta/packages/abiword/abiword_cvs.bb10
2 files changed, 73 insertions, 0 deletions
diff --git a/meta/packages/abiword/abiword.inc b/meta/packages/abiword/abiword.inc
new file mode 100644
index 0000000000..4c2b28fd71
--- /dev/null
+++ b/meta/packages/abiword/abiword.inc
@@ -0,0 +1,63 @@
1DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
2SECTION = "gnome/office"
3HOMEPAGE = "http://www.abiword.org""
4LICENSE = "GPLv2"
5
6DEPENDS = "libgsf libglade libfribidi libxml2 wv"
7RDEPENDS = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
8 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
9
10# Share this file between recipes that use cvs and that pull tarballs
11# (one day change this to differentiate automatically based on PV and set the
12# SRC_URI and S var directly)
13RELURI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
14RELSRC = "${WORKDIR}/abiword-${PV}/abi"
15
16CVSURI = "cvs://anoncvs:anoncvs@anoncvs.abisource.com/cvsroot;module=abi"
17CVSSRC = "${WORKDIR}/abi"
18
19#want 2.x from 2.x.y for the installation directory
20SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
21
22FILES_${PN} += " \
23 ${datadir}/icons/* \
24 ${datadir}/mime-info \
25 ${datadir}/abiword-${SHRT_VER}/glade \
26 ${datadir}/abiword-${SHRT_VER}/system.profile-en \
27 ${datadir}/abiword-${SHRT_VER}/system.profile-en-GB \
28# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
29# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
30 "
31
32inherit autotools pkgconfig
33
34PARALLEL_MAKE = ""
35
36# This is a minimalistic AbiWord build
37#
38# if you are planning to build plugins, make sure to comment out the
39# --disable-exports options
40
41EXTRA_OECONF = " --enable-embedded \
42 --disable-printing \
43 --with-sys-wv \
44 --disable-exports \
45 --disable-spellcheck"
46
47# TODO -- refactor this, so that instead of two strings and profiles
48# packages we have lots of locale packages, each with a set of strings and
49# a profile
50#
51PACKAGES += " abiword-strings abiword-systemprofiles"
52
53FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
54FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
55
56# AbiWord configure.ac does not play nicely with autoreconf
57# so use the autogen.sh script that comes with AbiWord
58#
59do_configure() {
60 cd ${S}
61 export NOCONFIGURE="no"; ./autogen.sh
62 oe_runconf
63}
diff --git a/meta/packages/abiword/abiword_cvs.bb b/meta/packages/abiword/abiword_cvs.bb
new file mode 100644
index 0000000000..2c27cc2083
--- /dev/null
+++ b/meta/packages/abiword/abiword_cvs.bb
@@ -0,0 +1,10 @@
1require abiword.inc
2
3SRCDATE="20070113"
4PV="2.5.0+cvs${SRCDATE}"
5PR = "r1"
6
7SRC_URI = "${CVSURI}"
8
9S = "${CVSSRC}"
10