summaryrefslogtreecommitdiffstats
path: root/meta/packages/abiword
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/abiword
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/abiword')
-rw-r--r--meta/packages/abiword/abiword-2.5.inc63
-rw-r--r--meta/packages/abiword/abiword-embedded_2.5.2.bb10
-rw-r--r--meta/packages/abiword/abiword.inc63
-rw-r--r--meta/packages/abiword/abiword_2.5.2.bb5
-rw-r--r--meta/packages/abiword/abiword_cvs.bb9
5 files changed, 0 insertions, 150 deletions
diff --git a/meta/packages/abiword/abiword-2.5.inc b/meta/packages/abiword/abiword-2.5.inc
deleted file mode 100644
index dcd3b85534..0000000000
--- a/meta/packages/abiword/abiword-2.5.inc
+++ /dev/null
@@ -1,63 +0,0 @@
1DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
2HOMEPAGE = "http://www.abiword.org"
3SECTION = "x11/office"
4LICENSE = "GPLv2"
5DEPENDS = "perl-native wv libgsf libglade libfribidi jpeg libpng libxml2"
6RDEPENDS = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
7 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
8
9SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
10
11#want 2.x from 2.x.y for the installation directory
12SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
13
14FILES_${PN} += " \
15 ${datadir}/icons/* \
16 ${datadir}/abiword-${SHRT_VER}/glade \
17 ${datadir}/abiword-${SHRT_VER}/scripts \
18 ${datadir}/abiword-${SHRT_VER}/system.profile-en \
19 ${datadir}/abiword-${SHRT_VER}/system.profile-en_GB \
20# ${datadir}/abiword-${SHRT_VER}/templates/A4.awt \
21# ${datadir}/abiword-${SHRT_VER}/templates/US-Letter.awt \
22 ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
23 ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
24 ${datadir}/abiword-${SHRT_VER}/templates/Employee-Directory.awt \
25 ${datadir}/abiword-${SHRT_VER}/templates/Business-Report.awt \
26 ${datadir}/abiword-${SHRT_VER}/templates/Fax-Coversheet.awt \
27 ${datadir}/abiword-${SHRT_VER}/templates/Resume.awt \
28 ${datadir}/abiword-${SHRT_VER}/templates/Two-Columns.awt \
29 ${datadir}/abiword-${SHRT_VER}/templates/Memo.awt \
30 ${datadir}/abiword-${SHRT_VER}/templates/Press-Release.awt "
31
32inherit autotools pkgconfig
33
34PARALLEL_MAKE = ""
35
36EXTRA_OECONF = " --disable-pspell \
37 --disable-spellcheck \
38 --disable-printing \
39 --disable-exports \
40 --with-sys-wv"
41
42# AbiWord configure.ac does not play nicely with autoreconf
43# so use the autogen.sh script that comes with AbiWord
44#
45do_configure() {
46 cd ${S}
47 export NOCONFIGURE="no"; ./autogen.sh
48 oe_runconf
49}
50
51
52do_install_append() {
53 install -d ${D}${datadir}/pixmaps/
54 mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
55}
56
57PACKAGES += " abiword-clipart abiword-icons abiword-strings abiword-systemprofiles abiword-templates "
58
59FILES_abiword-clipart += "${datadir}/abiword-${SHRT_VER}/clipart"
60FILES_abiword-icons += "${datadir}/abiword-${SHRT_VER}/icons"
61FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/AbiWord/strings"
62FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/AbiWord/system.profile*"
63FILES_abiword-templates += "${datadir}/abiword-${SHRT_VER}/templates"
diff --git a/meta/packages/abiword/abiword-embedded_2.5.2.bb b/meta/packages/abiword/abiword-embedded_2.5.2.bb
deleted file mode 100644
index 47cf9e03c0..0000000000
--- a/meta/packages/abiword/abiword-embedded_2.5.2.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1require abiword-2.5.inc
2
3EXTRA_OECONF += "--enable-embedded"
4
5S = "${WORKDIR}/abiword-${PV}"
6
7RCONFLICTS = "abiword"
8RPROVIDES += "abiword"
9
10
diff --git a/meta/packages/abiword/abiword.inc b/meta/packages/abiword/abiword.inc
deleted file mode 100644
index d2fabf931c..0000000000
--- a/meta/packages/abiword/abiword.inc
+++ /dev/null
@@ -1,63 +0,0 @@
1DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
2SECTION = "gnome/office"
3HOMEPAGE = "http://www.abiword.org""
4LICENSE = "GPLv2"
5
6DEPENDS = "libgsf libglade libfribidi libxml2 wv"
7RRECOMMENDS = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
8 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
9
10# Share this file between recipes that use cvs and that pull tarballs
11# (one day change this to differentiate automatically based on PV and set the
12# SRC_URI and S var directly)
13RELURI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
14RELSRC = "${WORKDIR}/abiword-${PV}/abi"
15
16CVSURI = "cvs://anoncvs:anoncvs@anoncvs.abisource.com/cvsroot;module=abi"
17CVSSRC = "${WORKDIR}/abi"
18
19#want 2.x from 2.x.y for the installation directory
20SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
21
22FILES_${PN} += " \
23 ${datadir}/icons/* \
24 ${datadir}/mime-info \
25 ${datadir}/abiword-${SHRT_VER}/glade \
26 ${datadir}/abiword-${SHRT_VER}/system.profile-en \
27 ${datadir}/abiword-${SHRT_VER}/system.profile-en-GB \
28# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
29# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
30 "
31
32inherit autotools pkgconfig
33
34PARALLEL_MAKE = ""
35
36# This is a minimalistic AbiWord build
37#
38# if you are planning to build plugins, make sure to comment out the
39# --disable-exports options
40
41EXTRA_OECONF = " --enable-embedded=poky \
42 --disable-printing \
43 --with-sys-wv \
44 --disable-exports \
45 --disable-spellcheck"
46
47# TODO -- refactor this, so that instead of two strings and profiles
48# packages we have lots of locale packages, each with a set of strings and
49# a profile
50#
51PACKAGES += " abiword-strings abiword-systemprofiles"
52
53FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
54FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
55
56# AbiWord configure.ac does not play nicely with autoreconf
57# so use the autogen.sh script that comes with AbiWord
58#
59do_configure() {
60 cd ${S}
61 export NOCONFIGURE="no"; ./autogen.sh
62 oe_runconf
63}
diff --git a/meta/packages/abiword/abiword_2.5.2.bb b/meta/packages/abiword/abiword_2.5.2.bb
deleted file mode 100644
index 566d0fa203..0000000000
--- a/meta/packages/abiword/abiword_2.5.2.bb
+++ /dev/null
@@ -1,5 +0,0 @@
1require abiword-2.5.inc
2
3PR = "r1"
4
5RCONFLICTS = "abiword-embedded"
diff --git a/meta/packages/abiword/abiword_cvs.bb b/meta/packages/abiword/abiword_cvs.bb
deleted file mode 100644
index e0e3bd7d60..0000000000
--- a/meta/packages/abiword/abiword_cvs.bb
+++ /dev/null
@@ -1,9 +0,0 @@
1require abiword.inc
2
3PV="2.5.0+cvs${SRCDATE}"
4PR = "r3"
5
6SRC_URI = "${CVSURI}"
7
8S = "${CVSSRC}"
9