summaryrefslogtreecommitdiffstats
path: root/meta/conf
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-04-09 08:20:36 (GMT)
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-10 12:32:00 (GMT)
commita0ccc1fb24f45da3688ce3cde09107e71b6de561 (patch)
treea67774edeb8454d439d0e4002ab3bae6196d2435 /meta/conf
parentb0550403d4e499a6c165c03825d3e4f9e2a750ad (diff)
downloadpoky-a0ccc1fb24f45da3688ce3cde09107e71b6de561.tar.gz
meta-toolchain: runqemu falied on FC16/Opensuse12.1 x86_64
runqemu can't launch a target image on Fedora 16 64bit or Opensuse 12.1 64bit, this is because runqemu needs the host's libGL.so, which requires GLIBC_2.14 which is defined in libc.so.6, but our default libc.so.6 is version 2.13, here is the message from Richard: The easiest solution would be to change the nativesdk libc to 2.15. I don't think we plan to do this for the target libc for 1.2 but we could change nativesdk's version if its well tested [YOCTO #1968] (From OE-Core rev: 5f1becfba0b801eeacb1c626659fe46cd6df25bf) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/conf')
-rw-r--r--meta/conf/distro/include/tcmode-default.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/conf/distro/include/tcmode-default.inc b/meta/conf/distro/include/tcmode-default.inc
index b481163..3dc0932 100644
--- a/meta/conf/distro/include/tcmode-default.inc
+++ b/meta/conf/distro/include/tcmode-default.inc
@@ -44,9 +44,9 @@ PREFERRED_VERSION_linux-libc-headers ?= "${LINUXLIBCVERSION}"
44PREFERRED_VERSION_linux-libc-headers-nativesdk ?= "${LINUXLIBCVERSION}" 44PREFERRED_VERSION_linux-libc-headers-nativesdk ?= "${LINUXLIBCVERSION}"
45PREFERRED_VERSION_eglibc ?= "${EGLIBCVERSION}" 45PREFERRED_VERSION_eglibc ?= "${EGLIBCVERSION}"
46PREFERRED_VERSION_eglibc-locale ?= "${EGLIBCVERSION}" 46PREFERRED_VERSION_eglibc-locale ?= "${EGLIBCVERSION}"
47PREFERRED_VERSION_eglibc-nativesdk ?= "${EGLIBCVERSION}" 47PREFERRED_VERSION_eglibc-nativesdk ?= "2.15"
48PREFERRED_VERSION_eglibc-initial ?= "${EGLIBCVERSION}" 48PREFERRED_VERSION_eglibc-initial ?= "${EGLIBCVERSION}"
49PREFERRED_VERSION_eglibc-initial-nativesdk ?= "${EGLIBCVERSION}" 49PREFERRED_VERSION_eglibc-initial-nativesdk ?= "2.15"
50PREFERRED_VERSION_cross-localedef-native ?= "${EGLIBCVERSION}" 50PREFERRED_VERSION_cross-localedef-native ?= "${EGLIBCVERSION}"
51PREFERRED_VERSION_uclibc ?= "${UCLIBCVERSION}" 51PREFERRED_VERSION_uclibc ?= "${UCLIBCVERSION}"
52PREFERRED_VERSION_uclibc-initial ?= "${UCLIBCVERSION}" 52PREFERRED_VERSION_uclibc-initial ?= "${UCLIBCVERSION}"