diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2014-07-23 11:33:01 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-07-25 16:54:43 +0100 |
commit | 68bc4eb778764e4fa66dd6296ca2042e7a9ebf67 (patch) | |
tree | a9a2a1f2ca1584c23fdf7d7b664a6558bb3e02d8 /meta/classes/utils.bbclass | |
parent | 8e26ab7d52edd13ffa50b2d0b26606bea8890e76 (diff) | |
download | poky-68bc4eb778764e4fa66dd6296ca2042e7a9ebf67.tar.gz |
insane: add checking to standardize how .bbappend files do FILESEXTRAPATHS
When adding patches or config files from bbappend files, it requires
the use of FILESEXTRAPATHS, which has been an issue and failure point
for people starting to work with bitbake and oe-core.
We add checking to standardize how to use FILESEXTRAPATHS. Only the
format of:
FILESEXTRAPATHS_append := ":${THISDIR}/Your_Files_Path" or
FILESEXTRAPATHS_prepend := "${THISDIR}/Your_Files_Path:"
is acceptable.
[YOCTO #5412]
(From OE-Core rev: 69e083237e632f7d84a7b218dd12d1a5ad95a229)
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/utils.bbclass')
-rw-r--r-- | meta/classes/utils.bbclass | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/classes/utils.bbclass b/meta/classes/utils.bbclass index 0ee13e04d7..0f2a484091 100644 --- a/meta/classes/utils.bbclass +++ b/meta/classes/utils.bbclass | |||
@@ -312,6 +312,8 @@ def explode_deps(s): | |||
312 | def base_set_filespath(path, d): | 312 | def base_set_filespath(path, d): |
313 | filespath = [] | 313 | filespath = [] |
314 | extrapaths = (d.getVar("FILESEXTRAPATHS", True) or "") | 314 | extrapaths = (d.getVar("FILESEXTRAPATHS", True) or "") |
315 | # Remove default flag which was used for checking | ||
316 | extrapaths = extrapaths.replace("__default:", "") | ||
315 | # Don't prepend empty strings to the path list | 317 | # Don't prepend empty strings to the path list |
316 | if extrapaths != "": | 318 | if extrapaths != "": |
317 | path = extrapaths.split(":") + path | 319 | path = extrapaths.split(":") + path |