diff options
author | Lianhao Lu <lianhao.lu@intel.com> | 2011-02-17 10:48:12 +0800 |
---|---|---|
committer | Saul Wold <sgw@linux.intel.com> | 2011-02-17 17:25:21 -0800 |
commit | 6dc50b17360dfde34d01125a6f9747fcb530be1d (patch) | |
tree | 8e0ff61160103ff320deb42868c8df7b6662aa80 /meta/classes/toolchain-scripts.bbclass | |
parent | f09f8f4aa32d134081a5bd8a5cff631a2e7935f7 (diff) | |
download | poky-6dc50b17360dfde34d01125a6f9747fcb530be1d.tar.gz |
toolchain-script/populate_sdk/meta-toolchain: moving common code.
moving common code between populate_sdk.bbclass and meta-environment.bb
into toolchain-script.bbclass.
Signed-off-by: Lianhao Lu <lianhao.lu@intel.com>
Diffstat (limited to 'meta/classes/toolchain-scripts.bbclass')
-rw-r--r-- | meta/classes/toolchain-scripts.bbclass | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/classes/toolchain-scripts.bbclass b/meta/classes/toolchain-scripts.bbclass index fb59761fd6..2b9cfac6a1 100644 --- a/meta/classes/toolchain-scripts.bbclass +++ b/meta/classes/toolchain-scripts.bbclass | |||
@@ -88,3 +88,27 @@ toolchain_create_sdk_env_script_for_installer () { | |||
88 | echo 'export POKY_DISTRO_VERSION="${DISTRO_VERSION}"' >> $script | 88 | echo 'export POKY_DISTRO_VERSION="${DISTRO_VERSION}"' >> $script |
89 | echo 'export POKY_SDK_VERSION="${SDK_VERSION}"' >> $script | 89 | echo 'export POKY_SDK_VERSION="${SDK_VERSION}"' >> $script |
90 | } | 90 | } |
91 | |||
92 | #This function create a site config file | ||
93 | toolchain_create_sdk_siteconfig () { | ||
94 | local siteconfig=$1 | ||
95 | shift | ||
96 | local files=$@ | ||
97 | |||
98 | rm -f $siteconfig | ||
99 | touch $siteconfig | ||
100 | for sitefile in ${files} ; do | ||
101 | cat $sitefile >> $siteconfig | ||
102 | done | ||
103 | } | ||
104 | |||
105 | #This function create a version information file | ||
106 | toolchain_create_sdk_version () { | ||
107 | local versionfile=$1 | ||
108 | rm -f $versionfile | ||
109 | touch $versionfile | ||
110 | echo 'Distro: ${DISTRO}' >> $versionfile | ||
111 | echo 'Distro Version: ${DISTRO_VERSION}' >> $versionfile | ||
112 | echo 'Metadata Revision: ${METADATA_REVISION}' >> $versionfile | ||
113 | echo 'Timestamp: ${DATETIME}' >> $versionfile | ||
114 | } | ||