summaryrefslogtreecommitdiffstats
path: root/meta/classes/sstate.bbclass
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-01-16 14:27:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-16 15:35:07 +0000
commit024b5af5481f47b636160172ca80993ddf5aaccb (patch)
tree874b456e2a5f6c5420cad03f5ff362d40d0920c9 /meta/classes/sstate.bbclass
parent46bd0598692b6e45f0da0b0e5e1bbe653460334c (diff)
downloadpoky-024b5af5481f47b636160172ca80993ddf5aaccb.tar.gz
sstate.bbclass: remove dependencies of SSTATE_EXTRAPATHWILDCARD
There might be do_cleansstate errors sometimes: ERROR: When reparsing /path/to/meta/recipes-devtools/quilt/quilt-native_0.65.bb.do_cleansstate, the basehash value changed from b4dbcb956a32ed4c3f58b7971717907bfc03bb21f3b140fa97f7765ee695f4d0 to c8307418a671686349b73efbd51c5c82c897a88707a759ddb22fd95baa5df2ba. The metadata is not deterministic and this needs to be fixed. The stable reproducer is: - Initial a fresh build, this is a must, otherwise we may can't reproduce it $ . oe-init-build-env build $ bitbake quilt-native -ccleansstate This is because uninative.bbclass resets NATIVELSBSTRING from distro (e.g., ubuntu) to universal, remove dependencies of SSTATE_EXTRAPATHWILDCARD as SSTATE_EXTRAPATH did can fix the problem. (From OE-Core rev: 781117f9f02c0080dadc8797a8f8f9377a99b164) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/sstate.bbclass')
-rw-r--r--meta/classes/sstate.bbclass1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/classes/sstate.bbclass b/meta/classes/sstate.bbclass
index 482ffa83f9..763fce07f9 100644
--- a/meta/classes/sstate.bbclass
+++ b/meta/classes/sstate.bbclass
@@ -23,6 +23,7 @@ PV[vardepvalue] = "${PV}"
23# We don't want the sstate to depend on things like the distro string 23# We don't want the sstate to depend on things like the distro string
24# of the system, we let the sstate paths take care of this. 24# of the system, we let the sstate paths take care of this.
25SSTATE_EXTRAPATH[vardepvalue] = "" 25SSTATE_EXTRAPATH[vardepvalue] = ""
26SSTATE_EXTRAPATHWILDCARD[vardepvalue] = ""
26 27
27# For multilib rpm the allarch packagegroup files can overwrite (in theory they're identical) 28# For multilib rpm the allarch packagegroup files can overwrite (in theory they're identical)
28SSTATE_DUPWHITELIST = "${DEPLOY_DIR}/licenses/" 29SSTATE_DUPWHITELIST = "${DEPLOY_DIR}/licenses/"