summaryrefslogtreecommitdiffstats
path: root/meta/classes/siteconfig.bbclass
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-01-18 16:18:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-25 12:25:46 +0000
commit7f41f1a8888a1f7f091101d19b9b0c4787f5a6fc (patch)
treeba2afa60ca17a84860545e0c871ffce34b57839a /meta/classes/siteconfig.bbclass
parentb0df35f47fb79dc149504bd66d1186b3276f9510 (diff)
downloadpoky-7f41f1a8888a1f7f091101d19b9b0c4787f5a6fc.tar.gz
bitbake: machine specific sysroots implementation
This commit changes the sysroots path to be machine specific. Changes includes: 1) STAGING_DIR_TARGET and STRAGING_DIR_HOST points to machine specific paths. 2) task stamp files. Adding ${MACHINE} info into stamp files for do_populate_sysroots and do_package tasks. Add a BB_STAMPTASK_BLACKLIST to keep native, nativesdk, crosssdk, and cross-canadian stamp unchanged. 3) siteconfig path. Separate the site config path for different machines to avoid one machine adopting the cache file of another machine. 4) sstate. Add machine name to sstate manifest file. Change relocation code for sstate paths since sysroot is machine. Keep native, nativesdk, crosssdk, and cross-canadian unchanged. 5) toolchain scripts. Change the environment path to point to machine specific sysroots in toolchain scripts bbclass. 6) Relocate la files when populating to a different machine of the same architecture. 7) Exclude STAGING_DIR_TARGET and STAGING_DIR_HOST parameter from sstate siginfo since they contain ${MACHINE} information. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/classes/siteconfig.bbclass')
-rw-r--r--meta/classes/siteconfig.bbclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/classes/siteconfig.bbclass b/meta/classes/siteconfig.bbclass
index 5edc0d6a0b..0813c2543e 100644
--- a/meta/classes/siteconfig.bbclass
+++ b/meta/classes/siteconfig.bbclass
@@ -13,10 +13,10 @@ python siteconfig_do_siteconfig () {
13EXTRASITECONFIG ?= "" 13EXTRASITECONFIG ?= ""
14 14
15siteconfig_do_siteconfig_gencache () { 15siteconfig_do_siteconfig_gencache () {
16 mkdir -p ${WORKDIR}/site_config 16 mkdir -p ${WORKDIR}/site_config_${MACHINE}
17 gen-site-config ${FILE_DIRNAME}/site_config \ 17 gen-site-config ${FILE_DIRNAME}/site_config \
18 >${WORKDIR}/site_config/configure.ac 18 >${WORKDIR}/site_config_${MACHINE}/configure.ac
19 cd ${WORKDIR}/site_config 19 cd ${WORKDIR}/site_config_${MACHINE}
20 autoconf 20 autoconf
21 CONFIG_SITE="" ${EXTRASITECONFIG} ./configure ${CONFIGUREOPTS} --cache-file ${PN}_cache 21 CONFIG_SITE="" ${EXTRASITECONFIG} ./configure ${CONFIGUREOPTS} --cache-file ${PN}_cache
22 sed -n -e "/ac_cv_c_bigendian/p" -e "/ac_cv_sizeof_/p" \ 22 sed -n -e "/ac_cv_c_bigendian/p" -e "/ac_cv_sizeof_/p" \