summaryrefslogtreecommitdiffstats
path: root/meta/classes/sign_rpm.bbclass
diff options
context:
space:
mode:
authorRandy Witt <randy.e.witt@linux.intel.com>2016-02-19 08:45:25 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-26 17:16:25 +0000
commit7bb9e8ddbfabfbaebe1b3cb635b6d9979854cc47 (patch)
tree2255b9e26f87d9aab9c92fe9f76d44f2ef421e8f /meta/classes/sign_rpm.bbclass
parent64ab17b707dc431aaed880d6d8615971243f46f8 (diff)
downloadpoky-7bb9e8ddbfabfbaebe1b3cb635b6d9979854cc47.tar.gz
signing-keys: Make signing keys the only publisher of keys
Previously the keys were put into the os-release package. The package indexing code was also deploying the keys rather than only using the keys. This change makes signing-keys.bb the only publisher of the keys and also uses standard tasks that already have sstate. (From OE-Core rev: 1e38068ac38dfd067655dfd41464e28439179306) Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/sign_rpm.bbclass')
-rw-r--r--meta/classes/sign_rpm.bbclass11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta/classes/sign_rpm.bbclass b/meta/classes/sign_rpm.bbclass
index 8b59bacd45..c21e3f09af 100644
--- a/meta/classes/sign_rpm.bbclass
+++ b/meta/classes/sign_rpm.bbclass
@@ -28,8 +28,11 @@ python () {
28 raise_sanity_error("You need to define %s in the config" % var, d) 28 raise_sanity_error("You need to define %s in the config" % var, d)
29 29
30 # Set the expected location of the public key 30 # Set the expected location of the public key
31 d.setVar('RPM_GPG_PUBKEY', os.path.join(d.getVar('STAGING_ETCDIR_NATIVE', False), 31 d.setVar('RPM_GPG_PUBKEY', os.path.join(d.getVar('STAGING_DIR_TARGET', False),
32 'RPM-GPG-PUBKEY')) 32 d.getVar('sysconfdir', False),
33 'pki',
34 'rpm-gpg',
35 'RPM-GPG-KEY-${DISTRO_VERSION}'))
33} 36}
34 37
35python sign_rpm () { 38python sign_rpm () {
@@ -44,5 +47,5 @@ python sign_rpm () {
44 d.getVar('RPM_GPG_PASSPHRASE_FILE', True)) 47 d.getVar('RPM_GPG_PASSPHRASE_FILE', True))
45} 48}
46 49
47do_package_index[depends] += "signing-keys:do_export_public_keys" 50do_package_index[depends] += "signing-keys:do_deploy"
48do_rootfs[depends] += "signing-keys:do_export_public_keys" 51do_rootfs[depends] += "signing-keys:do_populate_sysroot"