summaryrefslogtreecommitdiffstats
path: root/meta/classes/sign_package_feed.bbclass
diff options
context:
space:
mode:
authorRandy Witt <randy.e.witt@linux.intel.com>2016-02-19 08:45:25 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-26 17:16:25 +0000
commit7bb9e8ddbfabfbaebe1b3cb635b6d9979854cc47 (patch)
tree2255b9e26f87d9aab9c92fe9f76d44f2ef421e8f /meta/classes/sign_package_feed.bbclass
parent64ab17b707dc431aaed880d6d8615971243f46f8 (diff)
downloadpoky-7bb9e8ddbfabfbaebe1b3cb635b6d9979854cc47.tar.gz
signing-keys: Make signing keys the only publisher of keys
Previously the keys were put into the os-release package. The package indexing code was also deploying the keys rather than only using the keys. This change makes signing-keys.bb the only publisher of the keys and also uses standard tasks that already have sstate. (From OE-Core rev: 1e38068ac38dfd067655dfd41464e28439179306) Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/sign_package_feed.bbclass')
-rw-r--r--meta/classes/sign_package_feed.bbclass9
1 files changed, 2 insertions, 7 deletions
diff --git a/meta/classes/sign_package_feed.bbclass b/meta/classes/sign_package_feed.bbclass
index 63ca02fd9d..e1ec82e2ff 100644
--- a/meta/classes/sign_package_feed.bbclass
+++ b/meta/classes/sign_package_feed.bbclass
@@ -27,12 +27,7 @@ python () {
27 for var in ('PACKAGE_FEED_GPG_NAME', 'PACKAGE_FEED_GPG_PASSPHRASE_FILE'): 27 for var in ('PACKAGE_FEED_GPG_NAME', 'PACKAGE_FEED_GPG_PASSPHRASE_FILE'):
28 if not d.getVar(var, True): 28 if not d.getVar(var, True):
29 raise_sanity_error("You need to define %s in the config" % var, d) 29 raise_sanity_error("You need to define %s in the config" % var, d)
30
31 # Set expected location of the public key
32 d.setVar('PACKAGE_FEED_GPG_PUBKEY',
33 os.path.join(d.getVar('STAGING_ETCDIR_NATIVE', False),
34 'PACKAGE-FEED-GPG-PUBKEY'))
35} 30}
36 31
37do_package_index[depends] += "signing-keys:do_export_public_keys" 32do_package_index[depends] += "signing-keys:do_deploy"
38do_rootfs[depends] += "signing-keys:do_export_public_keys" 33do_rootfs[depends] += "signing-keys:do_populate_sysroot"