summaryrefslogtreecommitdiffstats
path: root/meta/classes/qt4x11.bbclass
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-01-21 15:38:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-01 15:57:26 +0000
commitc5998e6def9b320eb50247765b096743f6efbfe8 (patch)
treefde827d88e0afb56b10a43ace0a24c7de1d40b26 /meta/classes/qt4x11.bbclass
parent70ce04977c9d752430f9a01a01d6db5bf501ba42 (diff)
downloadpoky-c5998e6def9b320eb50247765b096743f6efbfe8.tar.gz
qt4: Bring in improvements from meta-openembedded
Differences from meta-openembedded version: * SRC_URI and S now come from qt-${PV}.inc since these are version specific * Source checksums are also now in qt-${PV}.inc * Remove do_compile as this is handled in qt-${PV}.inc * Move contents of do_install_append from qt-${PV}.inc to do_install in qt4.inc as this is the same for 4.6.3 and 4.7.1 and will get in the way of do_install_append in qt-embedded.inc. * Don't enable PostgreSQL, MySQL or SQLite 2.x plugins as we don't currently have recipes for these DBMSs in Poky. These can be re-enabled easily when or if we do. * Use INC_PR in qt4-x11-free_4.6.3.bb * Don't always specify -embedded config option in qt4.inc * Don't add qte.sh to SRC_URI in qt-4.6.3.inc (this is embedded-specific) Differences from what we have currently in Poky (plus the above): * Set DESCRIPTION based on embedded/X11 * Move out arch-specific settings to qt4-arch.inc * Add qt4x11.bbclass which can be inherited by application recipes to select the X11 version (this makes more sense once the embedded version is added). * Update HOMEPAGE Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/classes/qt4x11.bbclass')
-rw-r--r--meta/classes/qt4x11.bbclass9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/classes/qt4x11.bbclass b/meta/classes/qt4x11.bbclass
new file mode 100644
index 0000000000..abb1d9d2e4
--- /dev/null
+++ b/meta/classes/qt4x11.bbclass
@@ -0,0 +1,9 @@
1DEPENDS_prepend = "${@["qt4-x11-free ", ""][(bb.data.getVar('PN', d, 1)[:12] == 'qt4-x11-free')]}"
2
3inherit qmake2
4
5QT_DIR_NAME = "qt4"
6QT_LIBINFIX = ""
7
8# Qt4 uses atomic instructions not supported in thumb mode
9ARM_INSTRUCTION_SET = "arm"