summaryrefslogtreecommitdiffstats
path: root/meta/classes/python_pep517.bbclass
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-16 18:32:43 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-17 16:44:33 +0000
commit7fee41dcef576312e1f12ef485e9b07b9612569b (patch)
tree95dd71b64064021af04d59c495a1c948b9233534 /meta/classes/python_pep517.bbclass
parent6f5ee7fffb259516d7e715eeb68c89afceb9ef83 (diff)
downloadpoky-7fee41dcef576312e1f12ef485e9b07b9612569b.tar.gz
classes/python_pep517: consolidate stub do_configure
As PEP517 doesn't have an explicit configure step, we can stub out the do_configure task once instead of the calling classes doing it. (From OE-Core rev: fd17edbd00f1583eb9e1912ab269dd4dc2631a6f) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/python_pep517.bbclass')
-rw-r--r--meta/classes/python_pep517.bbclass8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/classes/python_pep517.bbclass b/meta/classes/python_pep517.bbclass
index 73bcf9ba07..34ffdc9c0d 100644
--- a/meta/classes/python_pep517.bbclass
+++ b/meta/classes/python_pep517.bbclass
@@ -22,6 +22,12 @@ PEP517_INSTALL_PYTHON:class-native = "nativepython3"
22# pypa/installer option to control the bytecode compilation 22# pypa/installer option to control the bytecode compilation
23INSTALL_WHEEL_COMPILE_BYTECODE ?= "--compile-bytecode=0" 23INSTALL_WHEEL_COMPILE_BYTECODE ?= "--compile-bytecode=0"
24 24
25# PEP517 doesn't have a specific configure step, so set an empty do_configure to avoid
26# running base_do_configure.
27python_pep517_do_configure () {
28 :
29}
30
25# When we have Python 3.11 we can parse pyproject.toml to determine the build 31# When we have Python 3.11 we can parse pyproject.toml to determine the build
26# API entry point directly 32# API entry point directly
27python_pep517_do_compile () { 33python_pep517_do_compile () {
@@ -47,4 +53,4 @@ python_pep517_do_bootstrap_install () {
47 unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PEP517_WHEEL_PATH}/*.whl 53 unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PEP517_WHEEL_PATH}/*.whl
48} 54}
49 55
50EXPORT_FUNCTIONS do_compile do_install 56EXPORT_FUNCTIONS do_configure do_compile do_install