diff options
author | Mikko Ylinen <mikko.ylinen@linux.intel.com> | 2017-04-13 13:09:07 +0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-04-14 09:47:08 +0100 |
commit | a84a323e4d72e40591446bd8aef37577ec084776 (patch) | |
tree | 9ef9e5c8087e8a1d1b6568a46e4e512f28621270 /meta/classes/populate_sdk_ext.bbclass | |
parent | bce0b509bf9c747c4877930f668717223e09ab96 (diff) | |
download | poky-a84a323e4d72e40591446bd8aef37577ec084776.tar.gz |
classes/populate_sdk_ext: reset TCLIBCAPPEND to get consistent TMPDIR
populate_sdk_ext sets TMPDIR to a known static value with '/tmp' directory
name and that name is hard coded in a few places (e.g., in
meta-environment-extsdk.bb that writes the eSDK environment variables).
Distros that do not reset TCLIBCAPPEND (poky does) end up getting
TMPDIR = /tmp-${TCLIBCAPPEND} via defaultsetup.conf and that breaks
the functionality in eSDK that expects everything is in /tmp.
To get TMPDIR consistent, we also need to reset TCLIBCAPPEND in
populate_sdk_ext.bbclass.
Fixes: [YOCTO #11298]
(From OE-Core rev: 9ec29153f279bb9e1dbcddc2c66e00fdbe3fd6e9)
Signed-off-by: Mikko Ylinen <mikko.ylinen@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/populate_sdk_ext.bbclass')
-rw-r--r-- | meta/classes/populate_sdk_ext.bbclass | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/classes/populate_sdk_ext.bbclass b/meta/classes/populate_sdk_ext.bbclass index db822bf771..21fd122468 100644 --- a/meta/classes/populate_sdk_ext.bbclass +++ b/meta/classes/populate_sdk_ext.bbclass | |||
@@ -114,6 +114,7 @@ def create_filtered_tasklist(d, sdkbasepath, tasklistfile, conf_initpath): | |||
114 | f.write('SSTATE_MIRRORS_forcevariable = ""\n') | 114 | f.write('SSTATE_MIRRORS_forcevariable = ""\n') |
115 | # Ensure TMPDIR is the default so that clean_esdk_builddir() can delete it | 115 | # Ensure TMPDIR is the default so that clean_esdk_builddir() can delete it |
116 | f.write('TMPDIR_forcevariable = "${TOPDIR}/tmp"\n') | 116 | f.write('TMPDIR_forcevariable = "${TOPDIR}/tmp"\n') |
117 | f.write('TCLIBCAPPEND_forcevariable = ""\n') | ||
117 | # Drop uninative if the build isn't using it (or else NATIVELSBSTRING will | 118 | # Drop uninative if the build isn't using it (or else NATIVELSBSTRING will |
118 | # be different and we won't be able to find our native sstate) | 119 | # be different and we won't be able to find our native sstate) |
119 | if not bb.data.inherits_class('uninative', d): | 120 | if not bb.data.inherits_class('uninative', d): |
@@ -289,6 +290,7 @@ python copy_buildsystem () { | |||
289 | f.write('\n') | 290 | f.write('\n') |
290 | 291 | ||
291 | f.write('TMPDIR = "${TOPDIR}/tmp"\n') | 292 | f.write('TMPDIR = "${TOPDIR}/tmp"\n') |
293 | f.write('TCLIBCAPPEND = ""\n') | ||
292 | f.write('DL_DIR = "${TOPDIR}/downloads"\n') | 294 | f.write('DL_DIR = "${TOPDIR}/downloads"\n') |
293 | 295 | ||
294 | f.write('INHERIT += "%s"\n' % 'uninative') | 296 | f.write('INHERIT += "%s"\n' % 'uninative') |