diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2012-07-20 17:49:16 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-07-20 12:32:52 +0100 |
commit | eb5522e9b049d47e35d60d1451aa5d5c356822d8 (patch) | |
tree | 169f9d79976a3485f2b1b0217b307d1096435484 /meta/classes/package_rpm.bbclass | |
parent | a6898ff7a55ec48f1450c8ef53210b82d74b1e5a (diff) | |
download | poky-eb5522e9b049d47e35d60d1451aa5d5c356822d8.tar.gz |
package_rpm: DEPLOY_DIR_RPM must exist before make index
There is a package-index.bb which will update the index, but the
DEPLOY_DIR_RPM may not exist, for example, when "bitbake package-index"
in a fresh build.
Only the package_rpm.bbclass needs this, the package_ipk.bbclass and
package_deb.bbclass doesn't need.
[YOCTO #2753]
(From OE-Core rev: 72e18bb4171698a386b277b12d973e3d0fd7c4cc)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/package_rpm.bbclass')
-rw-r--r-- | meta/classes/package_rpm.bbclass | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/package_rpm.bbclass b/meta/classes/package_rpm.bbclass index d213e40dee..983be4cfd0 100644 --- a/meta/classes/package_rpm.bbclass +++ b/meta/classes/package_rpm.bbclass | |||
@@ -22,7 +22,7 @@ RPMCONF_HOST_BASE = "${DEPLOY_DIR_RPM}/solvedb-sdk" | |||
22 | # Update the Packages depsolver db in ${DEPLOY_DIR_RPM} | 22 | # Update the Packages depsolver db in ${DEPLOY_DIR_RPM} |
23 | # | 23 | # |
24 | package_update_index_rpm () { | 24 | package_update_index_rpm () { |
25 | if [ ! -z "${DEPLOY_KEEP_PACKAGES}" ]; then | 25 | if [ ! -z "${DEPLOY_KEEP_PACKAGES}" -o ! -e "${DEPLOY_DIR_RPM}" ]; then |
26 | return | 26 | return |
27 | fi | 27 | fi |
28 | 28 | ||
@@ -1171,6 +1171,6 @@ do_package_write_rpm[dirs] = "${PKGWRITEDIRRPM}" | |||
1171 | do_package_write_rpm[umask] = "022" | 1171 | do_package_write_rpm[umask] = "022" |
1172 | addtask package_write_rpm before do_package_write after do_package | 1172 | addtask package_write_rpm before do_package_write after do_package |
1173 | 1173 | ||
1174 | PACKAGEINDEXES += "package_update_index_rpm; createrepo ${DEPLOY_DIR_RPM};" | 1174 | PACKAGEINDEXES += "package_update_index_rpm; [ ! -e ${DEPLOY_DIR_RPM} ] || createrepo ${DEPLOY_DIR_RPM};" |
1175 | PACKAGEINDEXDEPS += "rpm-native:do_populate_sysroot" | 1175 | PACKAGEINDEXDEPS += "rpm-native:do_populate_sysroot" |
1176 | PACKAGEINDEXDEPS += "createrepo-native:do_populate_sysroot" | 1176 | PACKAGEINDEXDEPS += "createrepo-native:do_populate_sysroot" |