summaryrefslogtreecommitdiffstats
path: root/meta/classes/package_rpm.bbclass
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-05-18 12:09:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-20 12:40:44 +0100
commit9fbd9b93aea780c8168f6de2692148b14dd9d6a7 (patch)
tree2a9aeccdcf807032bb309cd66dc35e6b320fd71b /meta/classes/package_rpm.bbclass
parent5956184bbe29fc24e1349035ec66cf57480fd63f (diff)
downloadpoky-9fbd9b93aea780c8168f6de2692148b14dd9d6a7.tar.gz
package-index.bb: add support for deb and rpm.
[YOCTO #1024] Currently package-index.bb only supports ipk. This commit adds the support for rpm and deb, too. ------------------------------ How to generate and use repos: 1) run "bitbake package-index" after building some target, e.g., core-image-sato-sdk; 2) export ${DEPLOY_DIR_RPM}, ${DEPLOY_DIR_IPK} and ${DEPLOY_DIR_DEB} by a webserver on the host, assuming the host IP is 192.168.7.1, at http://192.168.7.1/rpm http://192.168.7.1/ipk http://192.168.7.1/deb 3) inside the target, according to the packaging system (rpm, ipk or deb) used when we generate the target image, we can use different ways to manage packages: 3.1) RPM run "zypper addrepo http://192.168.7.1/rpm main; zypper refresh" to retrieve info about the repo; next, we can use "zypper install/remove" to manage packages. 3.2) IPK add the repo info into opkg config file, i.e., in /etc/opkg/arch.conf, we can add something like "src i586 http://192.168.7.1/ipk/i586", and next, we run "opkg update" to make opkg update the list of available packages. And later, we can use "opkg install/remove" to manage packages. 3.3) DEB Currently in target, some important config files, like /var/lib/dpkg/status and /etc/apt/sources.list, for deb/apt are missing. So we can't install/remove package in target at present. (From OE-Core rev: 01e34bdb43e0cc27c1cfffd6730c384f40c404c1) Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/package_rpm.bbclass')
-rw-r--r--meta/classes/package_rpm.bbclass3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/classes/package_rpm.bbclass b/meta/classes/package_rpm.bbclass
index 1cf9f798d3..b86356de2e 100644
--- a/meta/classes/package_rpm.bbclass
+++ b/meta/classes/package_rpm.bbclass
@@ -815,3 +815,6 @@ python do_package_write_rpm () {
815do_package_write_rpm[dirs] = "${PKGWRITEDIRRPM}" 815do_package_write_rpm[dirs] = "${PKGWRITEDIRRPM}"
816addtask package_write_rpm before do_package_write after do_package 816addtask package_write_rpm before do_package_write after do_package
817 817
818PACKAGEINDEXES += "package_update_index_rpm; createrepo ${DEPLOY_DIR_RPM};"
819PACKAGEINDEXDEPS += "rpm-native:do_populate_sysroot"
820PACKAGEINDEXDEPS += "createrepo-native:do_populate_sysroot"