diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2013-02-04 23:06:52 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-02-06 09:37:22 +0000 |
commit | 77b1409522abd9bef511a160ec2f768cdd3c7580 (patch) | |
tree | 49096409d9cd3b5436eda032a3bb577d39ec4f84 /meta/classes/package_ipk.bbclass | |
parent | 626dc8b98937bece2793b7f40761bb37b21f8771 (diff) | |
download | poky-77b1409522abd9bef511a160ec2f768cdd3c7580.tar.gz |
ipk: use OPKGLIBDIR in all places
* it's not recommended to change this value, because it breaks upgrade path on target
(all old u-a alternatives are forgot in old OPKGLIBDIR value
* but make it consistent, so if someone really want to change that, then
setting OPKGLIBDIR_distro in distro.conf would be enough
* without this there were at least 4 places to change:
rootfs_ipk: opkglibdir variable (notice that I've removed /opkg from it to correspond
with EXTRA_OECONF option used in opkg recipes
package_ipk: ${target_rootfs}${localstatedir}/lib/opkg/ hardcoded in
package_install_internal_ipk
opkg-collateral: value in lists file
opkg: EXTRA_OECONF for all 3 classes, FILES_libopkg, do_install
* validated with buildhistory that without OPKGLIBDIR explicitly set the
output is the same and that after setting
OPKGLIBDIR_forcevariable := "${libdir}"
everything including empty directory from package_ipk is moved to
libdir
(From OE-Core rev: cf0aa9c4fdae8855803e96b1922d54a2431795d3)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/package_ipk.bbclass')
-rw-r--r-- | meta/classes/package_ipk.bbclass | 4 |
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/classes/package_ipk.bbclass b/meta/classes/package_ipk.bbclass index 433d0bbe88..e46a52a022 100644 --- a/meta/classes/package_ipk.bbclass +++ b/meta/classes/package_ipk.bbclass | |||
@@ -12,6 +12,8 @@ OPKGBUILDCMD ??= "opkg-build" | |||
12 | 12 | ||
13 | OPKG_ARGS = "-f $INSTALL_CONF_IPK -o $INSTALL_ROOTFS_IPK --force_postinstall --prefer-arch-to-version" | 13 | OPKG_ARGS = "-f $INSTALL_CONF_IPK -o $INSTALL_ROOTFS_IPK --force_postinstall --prefer-arch-to-version" |
14 | 14 | ||
15 | OPKGLIBDIR = "${localstatedir}/lib" | ||
16 | |||
15 | python package_ipk_fn () { | 17 | python package_ipk_fn () { |
16 | d.setVar('PKGFN', d.getVar('PKG')) | 18 | d.setVar('PKGFN', d.getVar('PKG')) |
17 | } | 19 | } |
@@ -138,7 +140,7 @@ package_install_internal_ipk() { | |||
138 | local package_to_install="${INSTALL_PACKAGES_NORMAL_IPK}" | 140 | local package_to_install="${INSTALL_PACKAGES_NORMAL_IPK}" |
139 | local package_multilib="${INSTALL_PACKAGES_MULTILIB_IPK}" | 141 | local package_multilib="${INSTALL_PACKAGES_MULTILIB_IPK}" |
140 | 142 | ||
141 | mkdir -p ${target_rootfs}${localstatedir}/lib/opkg/ | 143 | mkdir -p ${target_rootfs}${OPKGLIBDIR}/opkg |
142 | 144 | ||
143 | local ipkg_args="${OPKG_ARGS}" | 145 | local ipkg_args="${OPKG_ARGS}" |
144 | 146 | ||