summaryrefslogtreecommitdiffstats
path: root/meta/classes/package_ipk.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-01 14:18:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-01 17:43:56 +0000
commit3001a4659d618c5e3e2750d779ee97f008300b12 (patch)
treeac28d8f208a3345dfd6710c4ec000bd92c38d925 /meta/classes/package_ipk.bbclass
parent91bc6fa5e20291b0ca1c6e60707086b1466339f9 (diff)
downloadpoky-3001a4659d618c5e3e2750d779ee97f008300b12.tar.gz
package_ipk: There is no longer any need to force owners/groups to root
Since the packaging process is run under pseudo, the default user is now root so there is no longer any need to hardcode this. Also take this opportunity to move the variable to package_ipk.bbclass since this is the only user of it. (From OE-Core rev: ea11f71432e2741d5f8c7cecec41c6155db34393) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/package_ipk.bbclass')
-rw-r--r--meta/classes/package_ipk.bbclass3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/classes/package_ipk.bbclass b/meta/classes/package_ipk.bbclass
index c0893a6cda..c97e36eeb2 100644
--- a/meta/classes/package_ipk.bbclass
+++ b/meta/classes/package_ipk.bbclass
@@ -7,6 +7,9 @@ IPKGCONF_SDK = "${WORKDIR}/opkg-sdk.conf"
7 7
8PKGWRITEDIRIPK = "${WORKDIR}/deploy-ipks" 8PKGWRITEDIRIPK = "${WORKDIR}/deploy-ipks"
9 9
10# Program to be used to build opkg packages
11OPKGBUILDCMD ??= "opkg-build"
12
10python package_ipk_fn () { 13python package_ipk_fn () {
11 bb.data.setVar('PKGFN', bb.data.getVar('PKG',d), d) 14 bb.data.setVar('PKGFN', bb.data.getVar('PKG',d), d)
12} 15}