diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2013-12-28 19:58:39 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-01-02 22:39:24 +0000 |
commit | 17aa50645015a149298e78a175bbd3cbf171df22 (patch) | |
tree | a2fe019a842ae8af18260a544c4c0772a62a464e /meta/classes/package.bbclass | |
parent | 6c6ae2a7bc6c6769d17227238f4911adf89e5abd (diff) | |
download | poky-17aa50645015a149298e78a175bbd3cbf171df22.tar.gz |
classes/package: set SUMMARY in do_split_packages()
do_split_packages() is commonly used to split out plugin/module packages
dynamically within recipes. If it doesn't set SUMMARY for each of these
packages then they get a generic SUMMARY from the recipe, which isn't
particularly useful; so add a parameter to set this and default it from
the current description parameter (it ought to have been the other way
around, but the description parameter is what we currently have in use
by all recipes that use this function.)
Fixes [YOCTO #5406].
(From OE-Core rev: 2b3080831042ffab26d70c3feee232fc31aa591a)
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/package.bbclass')
-rw-r--r-- | meta/classes/package.bbclass | 8 |
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/classes/package.bbclass b/meta/classes/package.bbclass index eb4cf44ef0..9b4f11aa30 100644 --- a/meta/classes/package.bbclass +++ b/meta/classes/package.bbclass | |||
@@ -72,7 +72,7 @@ def legitimize_package_name(s): | |||
72 | # Remaining package name validity fixes | 72 | # Remaining package name validity fixes |
73 | return s.lower().replace('_', '-').replace('@', '+').replace(',', '+').replace('/', '-') | 73 | return s.lower().replace('_', '-').replace('@', '+').replace(',', '+').replace('/', '-') |
74 | 74 | ||
75 | def do_split_packages(d, root, file_regex, output_pattern, description, postinst=None, recursive=False, hook=None, extra_depends=None, aux_files_pattern=None, postrm=None, allow_dirs=False, prepend=False, match_path=False, aux_files_pattern_verbatim=None, allow_links=False): | 75 | def do_split_packages(d, root, file_regex, output_pattern, description, postinst=None, recursive=False, hook=None, extra_depends=None, aux_files_pattern=None, postrm=None, allow_dirs=False, prepend=False, match_path=False, aux_files_pattern_verbatim=None, allow_links=False, summary=None): |
76 | """ | 76 | """ |
77 | Used in .bb files to split up dynamically generated subpackages of a | 77 | Used in .bb files to split up dynamically generated subpackages of a |
78 | given package, usually plugins or modules. | 78 | given package, usually plugins or modules. |
@@ -116,6 +116,8 @@ def do_split_packages(d, root, file_regex, output_pattern, description, postinst | |||
116 | package name. Can be a single string item or a list | 116 | package name. Can be a single string item or a list |
117 | of strings for multiple items. Must include %s. | 117 | of strings for multiple items. Must include %s. |
118 | allow_links -- True to allow symlinks to be matched - default False | 118 | allow_links -- True to allow symlinks to be matched - default False |
119 | summary -- Summary to set for each package. Must include %s; | ||
120 | defaults to description if not set. | ||
119 | 121 | ||
120 | """ | 122 | """ |
121 | 123 | ||
@@ -161,6 +163,9 @@ def do_split_packages(d, root, file_regex, output_pattern, description, postinst | |||
161 | if extra_depends == None: | 163 | if extra_depends == None: |
162 | extra_depends = d.getVar("PN", True) | 164 | extra_depends = d.getVar("PN", True) |
163 | 165 | ||
166 | if not summary: | ||
167 | summary = description | ||
168 | |||
164 | for o in sorted(objs): | 169 | for o in sorted(objs): |
165 | import re, stat | 170 | import re, stat |
166 | if match_path: | 171 | if match_path: |
@@ -206,6 +211,7 @@ def do_split_packages(d, root, file_regex, output_pattern, description, postinst | |||
206 | if extra_depends != '': | 211 | if extra_depends != '': |
207 | d.appendVar('RDEPENDS_' + pkg, ' ' + extra_depends) | 212 | d.appendVar('RDEPENDS_' + pkg, ' ' + extra_depends) |
208 | d.setVar('DESCRIPTION_' + pkg, description % on) | 213 | d.setVar('DESCRIPTION_' + pkg, description % on) |
214 | d.setVar('SUMMARY_' + pkg, summary % on) | ||
209 | if postinst: | 215 | if postinst: |
210 | d.setVar('pkg_postinst_' + pkg, postinst) | 216 | d.setVar('pkg_postinst_' + pkg, postinst) |
211 | if postrm: | 217 | if postrm: |