summaryrefslogtreecommitdiffstats
path: root/meta/classes/kernel.bbclass
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2018-01-24 19:12:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-20 09:59:32 +0000
commitd5075b648b06d3120fc7e4c47ccda3d620754590 (patch)
treee2fa14e3ec5d6d544f4bb8aed8144b2964675bcb /meta/classes/kernel.bbclass
parent6a8ef3d5a4e67f10a629d2ba6c1b6eb2e2240add (diff)
downloadpoky-d5075b648b06d3120fc7e4c47ccda3d620754590.tar.gz
kernel.bbclass: set HOSTLDFLAGS in KCONFIG_CONFIG_COMMAND
Kernel v4.14 and newer contain the following in their Makefile: HOST_LFS_LDFLAGS := $(shell getconf LFS_LDFLAGS) HOSTLDFLAGS := $(HOST_LFS_LDFLAGS) This breaks our menuconfig, because it can no longer find ncurses if its not on the host machine. This can be seen in linux-yocto-dev, for example: [clsulliv@clsulliv build]$ bitbake virtual/kernel -c menuconfig GEN ./Makefile HOSTLD scripts/kconfig/mconf /home/clsulliv/yocto/poky/build/tmp/hosttools/ld: cannot find -lncurses /home/clsulliv/yocto/poky/build/tmp/hosttools/ld: cannot find -ltinfo collect2: error: ld returned 1 exit status make[3]: *** [scripts/Makefile.host:99: scripts/kconfig/mconf] Error 1 make[2]: *** [/home/clsulliv/yocto/poky/build/tmp/work-shared/intel-corei7-64/kernel-source/Makefile:504: menuconfig] Error 2 make[1]: *** [Makefile:146: sub-make] Error 2 make: *** [Makefile:24: __sub-make] Error 2 Command failed. Press any key to continue... Fix this by setting HOSTLDFLAGS to ${BUILD_LDFLAGS} in our 'make menuconfig' command. (From OE-Core rev: 6afe8e211bfb3deb359194488f34a2c56f4b5ef6) Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/kernel.bbclass')
-rw-r--r--meta/classes/kernel.bbclass2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/classes/kernel.bbclass b/meta/classes/kernel.bbclass
index dc0152f74a..4877965af0 100644
--- a/meta/classes/kernel.bbclass
+++ b/meta/classes/kernel.bbclass
@@ -533,6 +533,8 @@ addtask savedefconfig after do_configure
533 533
534inherit cml1 534inherit cml1
535 535
536KCONFIG_CONFIG_COMMAND_append = " HOSTLDFLAGS='${BUILD_LDFLAGS}'"
537
536EXPORT_FUNCTIONS do_compile do_install do_configure 538EXPORT_FUNCTIONS do_compile do_install do_configure
537 539
538# kernel-base becomes kernel-${KERNEL_VERSION} 540# kernel-base becomes kernel-${KERNEL_VERSION}