diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-02-03 16:58:02 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-02-06 13:12:59 +0000 |
commit | 9244e4471d086ac25a5e40bb40abdfaf00c8e9cb (patch) | |
tree | a575b4eb1f1a2a8f4428b22cca09bf4107f7df44 /meta/classes/insane.bbclass | |
parent | 61c51a1a496f5dd3943f03cec245ead13a8bdb53 (diff) | |
download | poky-9244e4471d086ac25a5e40bb40abdfaf00c8e9cb.tar.gz |
insane.bbclass: Add documentation headers for logical code blocks
(From OE-Core rev: ac24487a05834cc9c02a95bbd281927d98c5886e)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/insane.bbclass')
-rw-r--r-- | meta/classes/insane.bbclass | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass index 3375a41ff6..1905c0dfdd 100644 --- a/meta/classes/insane.bbclass +++ b/meta/classes/insane.bbclass | |||
@@ -836,6 +836,10 @@ python do_qa_staging() { | |||
836 | python do_qa_configure() { | 836 | python do_qa_configure() { |
837 | import subprocess | 837 | import subprocess |
838 | 838 | ||
839 | ########################################################################### | ||
840 | # Check config.log for cross compile issues | ||
841 | ########################################################################### | ||
842 | |||
839 | configs = [] | 843 | configs = [] |
840 | workdir = d.getVar('WORKDIR', True) | 844 | workdir = d.getVar('WORKDIR', True) |
841 | bb.note("Checking autotools environment for common misconfiguration") | 845 | bb.note("Checking autotools environment for common misconfiguration") |
@@ -852,6 +856,10 @@ Rerun configure task after fixing this. The path was '%s'""" % root) | |||
852 | if "configure.in" in files: | 856 | if "configure.in" in files: |
853 | configs.append(os.path.join(root, "configure.in")) | 857 | configs.append(os.path.join(root, "configure.in")) |
854 | 858 | ||
859 | ########################################################################### | ||
860 | # Check gettext configuration and dependencies are correct | ||
861 | ########################################################################### | ||
862 | |||
855 | cnf = d.getVar('EXTRA_OECONF', True) or "" | 863 | cnf = d.getVar('EXTRA_OECONF', True) or "" |
856 | if "gettext" not in d.getVar('P', True) and "gcc-runtime" not in d.getVar('P', True) and "--disable-nls" not in cnf: | 864 | if "gettext" not in d.getVar('P', True) and "gcc-runtime" not in d.getVar('P', True) and "--disable-nls" not in cnf: |
857 | ml = d.getVar("MLPREFIX", True) or "" | 865 | ml = d.getVar("MLPREFIX", True) or "" |
@@ -869,8 +877,13 @@ Rerun configure task after fixing this. The path was '%s'""" % root) | |||
869 | bb.fatal("""%s required but not in DEPENDS for file %s. | 877 | bb.fatal("""%s required but not in DEPENDS for file %s. |
870 | Missing inherit gettext?""" % (gt, config)) | 878 | Missing inherit gettext?""" % (gt, config)) |
871 | 879 | ||
880 | ########################################################################### | ||
881 | # Check license variables | ||
882 | ########################################################################### | ||
883 | |||
872 | if not package_qa_check_license(workdir, d): | 884 | if not package_qa_check_license(workdir, d): |
873 | bb.fatal("Licensing Error: LIC_FILES_CHKSUM does not match, please fix") | 885 | bb.fatal("Licensing Error: LIC_FILES_CHKSUM does not match, please fix") |
886 | |||
874 | } | 887 | } |
875 | # The Staging Func, to check all staging | 888 | # The Staging Func, to check all staging |
876 | #addtask qa_staging after do_populate_sysroot before do_build | 889 | #addtask qa_staging after do_populate_sysroot before do_build |
@@ -886,6 +899,10 @@ python () { | |||
886 | if "desktop" in tests: | 899 | if "desktop" in tests: |
887 | d.appendVar("PACKAGE_DEPENDS", "desktop-file-utils-native") | 900 | d.appendVar("PACKAGE_DEPENDS", "desktop-file-utils-native") |
888 | 901 | ||
902 | ########################################################################### | ||
903 | # Check various variables | ||
904 | ########################################################################### | ||
905 | |||
889 | issues = [] | 906 | issues = [] |
890 | if (d.getVar('PACKAGES', True) or "").split(): | 907 | if (d.getVar('PACKAGES', True) or "").split(): |
891 | for var in 'RDEPENDS', 'RRECOMMENDS', 'FILES', 'pkg_preinst', 'pkg_postinst', 'pkg_prerm', 'pkg_postrm': | 908 | for var in 'RDEPENDS', 'RRECOMMENDS', 'FILES', 'pkg_preinst', 'pkg_postinst', 'pkg_prerm', 'pkg_postrm': |