summaryrefslogtreecommitdiffstats
path: root/meta/classes/insane.bbclass
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-04-22 11:28:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-04 00:54:47 +0100
commit499a7b911cdfb1f1ac3784f28e860930b014a941 (patch)
tree2e8c1e3ecaf989ba5f6775f3cf13bde6a55f7f5c /meta/classes/insane.bbclass
parent5ce6cc445a4e28b9afbc4d2b4697792294bcdf66 (diff)
downloadpoky-499a7b911cdfb1f1ac3784f28e860930b014a941.tar.gz
insane.bbclass: Checking for NLS too when checking gettext dependency
Checking for gettext is not needed when --disable-nls is used Let user know what variant of gettext is missing e.g. gettext-native, gettext-nativesdk etc, reveals a bit more for user Check for virtual/gettext (From OE-Core rev: 7d4cb46017616867dea589be03973897a02991eb) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/insane.bbclass')
-rw-r--r--meta/classes/insane.bbclass7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index a3ea0e5ef0..742be5e66a 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -578,7 +578,8 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
578 if "configure.in" in files: 578 if "configure.in" in files:
579 configs.append(os.path.join(root, "configure.in")) 579 configs.append(os.path.join(root, "configure.in"))
580 580
581 if "gettext" not in bb.data.getVar('P', d, True) and "gcc-runtime" not in bb.data.getVar('P', d, True): 581 cnf = bb.data.getVar('EXTRA_OECONF', d, True) or ""
582 if "gettext" not in bb.data.getVar('P', d, True) and "gcc-runtime" not in bb.data.getVar('P', d, True) and "--disable-nls" not in cnf:
582 if bb.data.inherits_class('native', d) or bb.data.inherits_class('cross', d) or bb.data.inherits_class('crosssdk', d) or bb.data.inherits_class('nativesdk', d): 583 if bb.data.inherits_class('native', d) or bb.data.inherits_class('cross', d) or bb.data.inherits_class('crosssdk', d) or bb.data.inherits_class('nativesdk', d):
583 gt = "gettext-native" 584 gt = "gettext-native"
584 elif bb.data.inherits_class('cross-canadian', d): 585 elif bb.data.inherits_class('cross-canadian', d):
@@ -590,8 +591,8 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
590 for config in configs: 591 for config in configs:
591 gnu = "grep \"^[[:space:]]*AM_GNU_GETTEXT\" %s >/dev/null" % config 592 gnu = "grep \"^[[:space:]]*AM_GNU_GETTEXT\" %s >/dev/null" % config
592 if os.system(gnu) == 0: 593 if os.system(gnu) == 0:
593 bb.fatal("""Gettext required but not in DEPENDS for file %s. 594 bb.fatal("""%s required but not in DEPENDS for file %s.
594Missing inherit gettext?""" % config) 595Missing inherit gettext?""" % (gt, config))
595 596
596 if not package_qa_check_license(workdir, d): 597 if not package_qa_check_license(workdir, d):
597 bb.fatal("Licensing Error: LIC_FILES_CHKSUM does not match, please fix") 598 bb.fatal("Licensing Error: LIC_FILES_CHKSUM does not match, please fix")