summaryrefslogtreecommitdiffstats
path: root/meta/classes/insane.bbclass
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2010-12-22 15:50:12 -0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-23 14:28:22 +0000
commit1c75a5df6845090480deff20f469f177501d2182 (patch)
tree1bf3ea8f59accedf8c107af802f9ff0951cf4184 /meta/classes/insane.bbclass
parent06b7c2e9a96aad700fff30c45448ad0b5d57f096 (diff)
downloadpoky-1c75a5df6845090480deff20f469f177501d2182.tar.gz
insane.bbclass: make LIC_FILES_CHKSUM failures report errors
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/classes/insane.bbclass')
-rw-r--r--meta/classes/insane.bbclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index b06d021b1b..225530a2c9 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -348,7 +348,7 @@ def package_qa_check_license(workdir, d):
348 if not lic_files: 348 if not lic_files:
349 # just throw a warning now. Once licensing data in entered for enough of the recipes, 349 # just throw a warning now. Once licensing data in entered for enough of the recipes,
350 # this will be converted into error and False will be returned. 350 # this will be converted into error and False will be returned.
351 bb.warn(pn + ": Recipe file does not have license file information (LIC_FILES_CHKSUM)") 351 bb.error(pn + ": Recipe file does not have license file information (LIC_FILES_CHKSUM)")
352 return True 352 return True
353 353
354 srcdir = bb.data.getVar('S', d, True) 354 srcdir = bb.data.getVar('S', d, True)
@@ -394,8 +394,8 @@ def package_qa_check_license(workdir, d):
394 bb.note ("md5 checksum matched for ", url) 394 bb.note ("md5 checksum matched for ", url)
395 else: 395 else:
396 bb.error ("md5 data is not matching for ", url) 396 bb.error ("md5 data is not matching for ", url)
397 bb.note ("The new md5 checksum is ", md5chksum) 397 bb.error ("The new md5 checksum is ", md5chksum)
398 bb.note ("Check if the license information has changed, and if it has update the .bb file with correct license") 398 bb.error ("Check if the license information has changed, and if it has update the .bb file with correct license")
399 sane = False 399 sane = False
400 400
401 return sane 401 return sane
@@ -605,5 +605,5 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
605Missing inherit gettext?""" % config) 605Missing inherit gettext?""" % config)
606 606
607 if not package_qa_check_license(workdir, d): 607 if not package_qa_check_license(workdir, d):
608 bb.fatal("Licensing warning: LIC_FILES_CHKSUM does not match, please fix") 608 bb.error("Licensing warning: LIC_FILES_CHKSUM does not match, please fix")
609} 609}