summaryrefslogtreecommitdiffstats
path: root/meta/classes/image_types.bbclass
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2012-03-09 15:05:12 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-13 11:45:11 +0000
commitfd6696a6f576676462fb9f0ef39bbd97083d49ae (patch)
treecd5e158c7c69d160dc3c005c2966a6995c671f84 /meta/classes/image_types.bbclass
parente867a99d97e3901bb71bad98ce9c6b82eef51736 (diff)
downloadpoky-fd6696a6f576676462fb9f0ef39bbd97083d49ae.tar.gz
image_types: ensure .rootfs.ext3 is created before vmdk is created.
In the case of self-hosted-image.bb, IMAGE_FSTYPES = "vmdk", so the variables alltypes and subimages don't contain ext3, and .rootfs.ext3 won't be created, and finally the generated .hddimg and .vmdk don't have an actual rootfs -- the size of the .vmdk file is only about 9MB. [YOCTO #2067] (From OE-Core rev: 39f14c66d5df226689238810b759f502644deb5c) Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/image_types.bbclass')
-rw-r--r--meta/classes/image_types.bbclass6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/classes/image_types.bbclass b/meta/classes/image_types.bbclass
index 8b820182e2..e92f519078 100644
--- a/meta/classes/image_types.bbclass
+++ b/meta/classes/image_types.bbclass
@@ -26,13 +26,19 @@ def get_imagecmds(d):
26 # Live and VMDK images will be processed via inheriting 26 # Live and VMDK images will be processed via inheriting
27 # bbclass and does not get processed here. 27 # bbclass and does not get processed here.
28 # vmdk depend on live images also depend on ext3 so ensure its present 28 # vmdk depend on live images also depend on ext3 so ensure its present
29 # Note: we need to ensure ext3 is in alltypes, otherwise, subimages may
30 # not contain ext3 and the .rootfs.ext3 file won't be created.
29 if "vmdk" in types: 31 if "vmdk" in types:
30 if "ext3" not in types: 32 if "ext3" not in types:
31 types.append("ext3") 33 types.append("ext3")
34 if "ext3" not in alltypes:
35 alltypes.append("ext3")
32 types.remove("vmdk") 36 types.remove("vmdk")
33 if "live" in types: 37 if "live" in types:
34 if "ext3" not in types: 38 if "ext3" not in types:
35 types.append("ext3") 39 types.append("ext3")
40 if "ext3" not in alltypes:
41 alltypes.append("ext3")
36 types.remove("live") 42 types.remove("live")
37 43
38 if d.getVar('IMAGE_LINK_NAME', True): 44 if d.getVar('IMAGE_LINK_NAME', True):