summaryrefslogtreecommitdiffstats
path: root/meta/classes/image.bbclass
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-05-13 02:17:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-14 15:02:36 +0300
commit0c8173d7dcd5d3338f6619ad39cb17fc241a8123 (patch)
treed3e2ae6130b560a533ba0695bf000f721ec163d3 /meta/classes/image.bbclass
parent4f070506df3aed5d90391366895d5400d5a712c4 (diff)
downloadpoky-0c8173d7dcd5d3338f6619ad39cb17fc241a8123.tar.gz
image.bbclass: Add package-management image feature to validitems
Some images dont use core-image bbclass and add this feature directly Fixes parsing errors like /builds1/angstrom/cache/prserv.sqlite3, IP: 127.0.0.1, PORT: 34734, PID: 24551 Parsing recipes...ERROR: Unable to parse /builds1/angstrom/sources/meta-kde/recipes-images/angstrom-kde-desktop-imag e.bb: Exited with "1" ERROR: 'package-management' in IMAGE_FEATURES is not a valid image feature. Valid features: dbg-pkgs debug-tweaks dev-pkgs doc-pkgs ptest-pkgs read-only-rootfs splash staticdev-pkgs ERROR: 'package-management' in IMAGE_FEATURES is not a valid image feature. Valid features: dbg-pkgs debug-tweaks dev-pkgs doc-pkgs ptest-pkgs read-only-rootfs splash staticdev-pkgs ERROR: Command execution failed: Exited with 1 (From OE-Core rev: f9f1397d688cc4eb8d736066b1280bee40a8916a) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/image.bbclass')
-rw-r--r--meta/classes/image.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/image.bbclass b/meta/classes/image.bbclass
index 2b42e123ed..4f077082da 100644
--- a/meta/classes/image.bbclass
+++ b/meta/classes/image.bbclass
@@ -19,7 +19,7 @@ INHIBIT_DEFAULT_DEPS = "1"
19# IMAGE_FEATURES may contain any available package group 19# IMAGE_FEATURES may contain any available package group
20IMAGE_FEATURES ?= "" 20IMAGE_FEATURES ?= ""
21IMAGE_FEATURES[type] = "list" 21IMAGE_FEATURES[type] = "list"
22IMAGE_FEATURES[validitems] += "debug-tweaks read-only-rootfs" 22IMAGE_FEATURES[validitems] += "debug-tweaks read-only-rootfs package-management"
23 23
24# rootfs bootstrap install 24# rootfs bootstrap install
25ROOTFS_BOOTSTRAP_INSTALL = "${@base_contains("IMAGE_FEATURES", "package-management", "", "${ROOTFS_PKGMANAGE_BOOTSTRAP}",d)}" 25ROOTFS_BOOTSTRAP_INSTALL = "${@base_contains("IMAGE_FEATURES", "package-management", "", "${ROOTFS_PKGMANAGE_BOOTSTRAP}",d)}"