summaryrefslogtreecommitdiffstats
path: root/meta/classes/icecc.bbclass
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-12-04 23:10:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-05 14:25:27 +0000
commitf750d65e15e4305e42e2d390fd741b1b0e6ad4fe (patch)
tree6a81fecc72a574cfb26850004f670bc587b67371 /meta/classes/icecc.bbclass
parentcae2315266b704614fe1d7bdeef004ef67a01e8d (diff)
downloadpoky-f750d65e15e4305e42e2d390fd741b1b0e6ad4fe.tar.gz
icecc.bbclass: Fix whitespace, improve comment
* Add leading space in big documentation block at the top * Drop trailing spaces in code * Update documentation to mention 'bb.utils.which' instead of 'which' (From OE-Core rev: e220c8e308caac6ef1da038697927425a807d2f2) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/icecc.bbclass')
-rw-r--r--meta/classes/icecc.bbclass29
1 files changed, 15 insertions, 14 deletions
diff --git a/meta/classes/icecc.bbclass b/meta/classes/icecc.bbclass
index d7407d2ed5..7147d2f7af 100644
--- a/meta/classes/icecc.bbclass
+++ b/meta/classes/icecc.bbclass
@@ -8,21 +8,22 @@
8# For the cross compiler, creates a tar.gz of our toolchain and sets 8# For the cross compiler, creates a tar.gz of our toolchain and sets
9# ICECC_VERSION accordingly. 9# ICECC_VERSION accordingly.
10# 10#
11#The class now handles all 3 different compile 'stages' (i.e native ,cross-kernel and target) creating the 11# The class now handles all 3 different compile 'stages' (i.e native ,cross-kernel and target) creating the
12#necessary environment tar.gz file to be used by the remote machines. 12# necessary environment tar.gz file to be used by the remote machines.
13#It also supports meta-toolchain generation 13# It also supports meta-toolchain generation
14# 14#
15#If ICECC_PATH is not set in local.conf then the class will try to locate it using 'which' 15# If ICECC_PATH is not set in local.conf then the class will try to locate it using 'bb.utils.which'
16#but nothing is sure ;) 16# but nothing is sure ;)
17# 17#
18#If ICECC_ENV_EXEC is set in local.conf should point to the icecc-create-env script provided by the user 18# If ICECC_ENV_EXEC is set in local.conf, then it should point to the icecc-create-env script provided by the user
19#or the default one provided by icecc-create-env.bb will be used 19# or the default one provided by icecc-create-env.bb will be used
20#(NOTE that this is a modified version of the script need it and *not the one that comes with icecc* 20# (NOTE that this is a modified version of the script need it and *not the one that comes with icecc*
21#
22# User can specify if specific packages or packages belonging to class should not use icecc to distribute
23# compile jobs to remote machines, but handled locally, by defining ICECC_USER_CLASS_BL and ICECC_USER_PACKAGE_BL
24# with the appropriate values in local.conf. In addition the user can force to enable icecc for packages
25# which set an empty PARALLEL_MAKE variable by defining ICECC_USER_PACKAGE_WL.
21# 26#
22#User can specify if specific packages or packages belonging to class should not use icecc to distribute
23#compile jobs to remote machines, but handled locally, by defining ICECC_USER_CLASS_BL and ICECC_USER_PACKAGE_BL
24#with the appropriate values in local.conf. In addition the user can force to enable icecc for packages
25#which set an empty PARALLEL_MAKE variable by defining ICECC_USER_PACKAGE_WL.
26######################################################################################### 27#########################################################################################
27#Error checking is kept to minimum so double check any parameters you pass to the class 28#Error checking is kept to minimum so double check any parameters you pass to the class
28########################################################################################### 29###########################################################################################
@@ -96,7 +97,7 @@ def use_icc(bb,d):
96 97
97 package_tmp = d.expand('${PN}') 98 package_tmp = d.expand('${PN}')
98 99
99 system_class_blacklist = [ "none" ] 100 system_class_blacklist = [ "none" ]
100 user_class_blacklist = (d.getVar('ICECC_USER_CLASS_BL') or "none").split() 101 user_class_blacklist = (d.getVar('ICECC_USER_CLASS_BL') or "none").split()
101 package_class_blacklist = system_class_blacklist + user_class_blacklist 102 package_class_blacklist = system_class_blacklist + user_class_blacklist
102 103
@@ -174,7 +175,7 @@ def icc_path(bb,d):
174 175
175 else: 176 else:
176 prefix = d.expand('${HOST_PREFIX}') 177 prefix = d.expand('${HOST_PREFIX}')
177 return create_path( [prefix+"gcc", prefix+"g++"], bb, d) 178 return create_path( [prefix+"gcc", prefix+"g++"], bb, d)
178 179
179def icc_get_external_tool(bb, d, tool): 180def icc_get_external_tool(bb, d, tool):
180 external_toolchain_bindir = d.expand('${EXTERNAL_TOOLCHAIN}${bindir_cross}') 181 external_toolchain_bindir = d.expand('${EXTERNAL_TOOLCHAIN}${bindir_cross}')