summaryrefslogtreecommitdiffstats
path: root/meta/classes/grub-efi.bbclass
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-07-03 21:05:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-19 17:49:48 +0100
commit64f7feb5c37d06e1985c59106cf2f7cd286fd0b8 (patch)
treea016868a9546b81060b0d3b5ff9e33fcea46bad6 /meta/classes/grub-efi.bbclass
parentd36fa9a8835cd5aa6e14800d862b1a9da4dae30a (diff)
downloadpoky-64f7feb5c37d06e1985c59106cf2f7cd286fd0b8.tar.gz
EFI: Make installer EFI aware
[YOCTO #1919] Create a basic EFI installer script modeled after the existing installer and add it to a new initramfs-live-install-efi recipe. Update the init-live.sh script to distinguish between LABEL=install and LABEL=install-efi and select the appropriate script. Add the efi installer to core-image-minimal-initramfs. Update grub-efi.bbclass to use "LABEL=install-efi" when it detects a label of "install". This is clearly not ideal, but a proper fix would involve decoupling the LABELS assignment from the image-live.bbclass usage of SYSLINUX_LABELS. We should be able to address that in a follow-on clean-up series. V2: Include missing initramfs-live-install-efi_1.0.bb V3: Rebase after Radu's console_params fix (From OE-Core rev: 4bce3417917a3e88ba6529db394525fba82e0699) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/grub-efi.bbclass')
-rw-r--r--meta/classes/grub-efi.bbclass2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/classes/grub-efi.bbclass b/meta/classes/grub-efi.bbclass
index 1efb43b805..147accc895 100644
--- a/meta/classes/grub-efi.bbclass
+++ b/meta/classes/grub-efi.bbclass
@@ -99,6 +99,8 @@ python build_grub_cfg() {
99 bb.data.update_data(localdata) 99 bb.data.update_data(localdata)
100 100
101 cfgfile.write('\nmenuentry \'%s\'{\n' % (label)) 101 cfgfile.write('\nmenuentry \'%s\'{\n' % (label))
102 if label == "install":
103 label = "install-efi"
102 cfgfile.write('linux /vmlinuz LABEL=%s' % (label)) 104 cfgfile.write('linux /vmlinuz LABEL=%s' % (label))
103 105
104 append = localdata.getVar('APPEND', True) 106 append = localdata.getVar('APPEND', True)