diff options
author | Ricardo Ribalda Delgado <ricardo@ribalda.com> | 2019-06-21 10:06:02 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-06-21 15:32:36 +0100 |
commit | 1a82468d2d94b44cc122ee2172014d712e35563d (patch) | |
tree | 072265c51ded24b86f05d8b13b1508a67ead01ca /meta/classes/go.bbclass | |
parent | ed2a19f87e6e2d2a20d922f53c54632631fdcdc4 (diff) | |
download | poky-1a82468d2d94b44cc122ee2172014d712e35563d.tar.gz |
go: avoid host contamination by GOCACHE
By default GOCACHE is set to $HOME/.cache.
Fixes:
ERROR: go-cross-dbfp4-1.12.1-r0 do_compile: Function failed: do_compile (log file is located at /workdir/build/tmp/work/x86_64-linux/go-cross-dbfp4/1.12.1-r0/temp/log.do_compile.8120)
ERROR: Logfile of failure stored in: /workdir/build/tmp/work/x86_64-linux/go-cross-dbfp4/1.12.1-r0/temp/log.do_compile.8120
Log data follows:
| DEBUG: Executing shell function do_compile
| Building Go cmd/dist using /workdir/build/tmp/work/x86_64-linux/go-cross-dbfp4/1.12.1-r0/recipe-sysroot-native/usr/lib/go.
| failed to initialize build cache at /home/pokyuser/.cache/go-build: mkdir /home/pokyuser/.cache: permission denied
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_compile (log file is located at /workdir/build/tmp/work/x86_64-linux/go-cross-dbfp4/1.12.1-r0/temp/log.do_compile.8120)
ERROR: Task (/workdir/repo/poky/meta/recipes-devtools/go/go-cross_1.12.bb:do_compile) failed with exit code '1'
NOTE: Tasks Summary: Attempted 23 tasks of which 16 didn't need to be rerun and 1 failed.
(From OE-Core rev: 9a6d208b9979035bbfc1def80fb6558db4bddb12)
Signed-off-by: Ricardo Ribalda Delgado <ricardo@ribalda.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/go.bbclass')
-rw-r--r-- | meta/classes/go.bbclass | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/classes/go.bbclass b/meta/classes/go.bbclass index b6d9372c56..e05a5c641c 100644 --- a/meta/classes/go.bbclass +++ b/meta/classes/go.bbclass | |||
@@ -7,6 +7,7 @@ GOROOT_class-nativesdk = "${STAGING_DIR_TARGET}${libdir}/go" | |||
7 | GOROOT = "${STAGING_LIBDIR}/go" | 7 | GOROOT = "${STAGING_LIBDIR}/go" |
8 | export GOROOT | 8 | export GOROOT |
9 | export GOROOT_FINAL = "${libdir}/go" | 9 | export GOROOT_FINAL = "${libdir}/go" |
10 | export GOCACHE = "${B}/.cache" | ||
10 | 11 | ||
11 | export GOARCH = "${TARGET_GOARCH}" | 12 | export GOARCH = "${TARGET_GOARCH}" |
12 | export GOOS = "${TARGET_GOOS}" | 13 | export GOOS = "${TARGET_GOOS}" |