diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2018-07-17 21:36:35 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-07-26 13:16:40 +0100 |
commit | 8fdbb0381dc7d9beee30c38e41e140b0a7c2838b (patch) | |
tree | d4a517db2586fdb0926fc31599c70fd9f5e0f1b8 /meta/classes/distutils3.bbclass | |
parent | 206f8102a45e5e91657dd6e8c098ffe0f257b1cc (diff) | |
download | poky-8fdbb0381dc7d9beee30c38e41e140b0a7c2838b.tar.gz |
distutils/setuptools-native, distutils3/setuptools3-native: do not try to fetch code during do_compile
If a python recipe is using setuptools and the setup_requires argument, where
setuptools will use easy_install to fetch the module if it isn't
present.
The build failed on a machine where a proxy was required, but succeeded on a
machine which had direct access to the internet
Add var-NO_FETCH_BUILD, and set it in distutils_do_compile which does not
allow to fetch code from internet during do_compile.
Example result:
...
ERROR: Do not try to fetch `pytest-runner1' for building. Please add its native recipe to DEPENDS.
Traceback (most recent call last):
File "setup.py", line 56, in <module>
...
The improvement is flexible for test_requirements argument (used at
`setup.py test'), where use easy_install also.
[YOCTO #12084]
(From OE-Core rev: 57414f4a1c549e6faaa110e6e95ff601b05b7361)
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/distutils3.bbclass')
-rw-r--r-- | meta/classes/distutils3.bbclass | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/classes/distutils3.bbclass b/meta/classes/distutils3.bbclass index d4b92a3bb2..f8aca5e62f 100644 --- a/meta/classes/distutils3.bbclass +++ b/meta/classes/distutils3.bbclass | |||
@@ -15,6 +15,7 @@ distutils3_do_configure() { | |||
15 | } | 15 | } |
16 | 16 | ||
17 | distutils3_do_compile() { | 17 | distutils3_do_compile() { |
18 | NO_FETCH_BUILD=1 \ | ||
18 | STAGING_INCDIR=${STAGING_INCDIR} \ | 19 | STAGING_INCDIR=${STAGING_INCDIR} \ |
19 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | 20 | STAGING_LIBDIR=${STAGING_LIBDIR} \ |
20 | ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \ | 21 | ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \ |