diff options
author | Douglas Royds <douglas.royds@taitradio.com> | 2019-05-14 17:55:59 +1200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-05-15 17:53:29 +0100 |
commit | 3de77b33eecbf6e65e5d9d1eedb5f2aea3886766 (patch) | |
tree | 67aae93c300143b6f4f8179cbd2389426fd81e57 /meta/classes/distutils3.bbclass | |
parent | 2537269bf53b99827191390ce9f9205cc821ec54 (diff) | |
download | poky-3de77b33eecbf6e65e5d9d1eedb5f2aea3886766.tar.gz |
distutils: Tidy and simplify for readability
Line lengths, remove duplication, and use the PYTHON variable provided by
pythonnative.bbclass.
Coincidentally fixes a dormant defect in distutils3.bbclass in which we were
sedding for STAGING_BINDIR_NATIVE/python-python3/python3.
(From OE-Core rev: 7b8dd17c65e2d7d163f452833f21469918bf222e)
Signed-off-by: Douglas Royds <douglas.royds@taitradio.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/distutils3.bbclass')
-rw-r--r-- | meta/classes/distutils3.bbclass | 22 |
1 files changed, 8 insertions, 14 deletions
diff --git a/meta/classes/distutils3.bbclass b/meta/classes/distutils3.bbclass index 42e7f5ae53..05a24bfe26 100644 --- a/meta/classes/distutils3.bbclass +++ b/meta/classes/distutils3.bbclass | |||
@@ -56,24 +56,18 @@ distutils3_do_install() { | |||
56 | bbfatal_log "'${PYTHON_PN} setup.py install ${DISTUTILS_INSTALL_ARGS}' execution failed." | 56 | bbfatal_log "'${PYTHON_PN} setup.py install ${DISTUTILS_INSTALL_ARGS}' execution failed." |
57 | 57 | ||
58 | # support filenames with *spaces* | 58 | # support filenames with *spaces* |
59 | find ${D} -name "*.py" -exec grep -q ${D} {} \; -exec sed -i -e s:${D}::g {} \; | 59 | find ${D} -name "*.py" -exec grep -q ${D} {} \; \ |
60 | -exec sed -i -e s:${D}::g {} \; | ||
60 | 61 | ||
61 | if test -e ${D}${bindir} ; then | 62 | for i in ${D}${bindir}/* ${D}${sbindir}/*; do |
62 | for i in ${D}${bindir}/* ; do \ | 63 | if [ -f "$i" ]; then |
63 | sed -i -e s:${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN}:${USRBINPATH}/env\ ${DISTUTILS_PYTHON}:g $i | 64 | sed -i -e s:${PYTHON}:${USRBINPATH}/env\ ${DISTUTILS_PYTHON}:g $i |
64 | sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i | 65 | sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i |
65 | done | 66 | fi |
66 | fi | 67 | done |
67 | |||
68 | if test -e ${D}${sbindir}; then | ||
69 | for i in ${D}${sbindir}/* ; do \ | ||
70 | sed -i -e s:${STAGING_BINDIR_NATIVE}/python-${PYTHON_PN}/${PYTHON_PN}:${USRBINPATH}/env\ ${DISTUTILS_PYTHON}:g $i | ||
71 | sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i | ||
72 | done | ||
73 | fi | ||
74 | 68 | ||
75 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/easy-install.pth | 69 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/easy-install.pth |
76 | 70 | ||
77 | # | 71 | # |
78 | # FIXME: Bandaid against wrong datadir computation | 72 | # FIXME: Bandaid against wrong datadir computation |
79 | # | 73 | # |