diff options
author | Richard Purdie <richard@rex.(none)> | 2009-12-05 23:18:02 +0000 |
---|---|---|
committer | Richard Purdie <richard@rex.(none)> | 2009-12-05 23:18:02 +0000 |
commit | 288e62a22115a32effc65efa7c2d6ef2867d0b91 (patch) | |
tree | e316e1034e26300b44f7cdfc297b73727f3242f3 /meta/classes/distutils.bbclass | |
parent | c7d4ad8e9dce735cf52caaf38afe2392301b2536 (diff) | |
download | poky-288e62a22115a32effc65efa7c2d6ef2867d0b91.tar.gz |
distutils: Sync with OE.dev
Signed-off-by: Richard Purdie <richard@rex.(none)>
Diffstat (limited to 'meta/classes/distutils.bbclass')
-rw-r--r-- | meta/classes/distutils.bbclass | 13 |
1 files changed, 10 insertions, 3 deletions
diff --git a/meta/classes/distutils.bbclass b/meta/classes/distutils.bbclass index 0b9bdfe1a9..245ef7d859 100644 --- a/meta/classes/distutils.bbclass +++ b/meta/classes/distutils.bbclass | |||
@@ -25,10 +25,10 @@ distutils_stage_headers() { | |||
25 | } | 25 | } |
26 | 26 | ||
27 | distutils_stage_all() { | 27 | distutils_stage_all() { |
28 | install -d ${STAGING_DIR_HOST}${prefix}/${PYTHON_DIR}/site-packages | ||
29 | STAGING_INCDIR=${STAGING_INCDIR} \ | 28 | STAGING_INCDIR=${STAGING_INCDIR} \ |
30 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | 29 | STAGING_LIBDIR=${STAGING_LIBDIR} \ |
31 | PYTHONPATH=${STAGING_DIR_HOST}${prefix}/${PYTHON_DIR}/site-packages \ | 30 | install -d ${STAGING_DIR_HOST}${libdir}/${PYTHON_DIR}/site-packages |
31 | PYTHONPATH=${STAGING_DIR_HOST}${libdir}/${PYTHON_DIR}/site-packages \ | ||
32 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | 32 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ |
33 | ${STAGING_BINDIR_NATIVE}/python setup.py install ${DISTUTILS_STAGE_ALL_ARGS} || \ | 33 | ${STAGING_BINDIR_NATIVE}/python setup.py install ${DISTUTILS_STAGE_ALL_ARGS} || \ |
34 | oefatal "python setup.py install (stage) execution failed." | 34 | oefatal "python setup.py install (stage) execution failed." |
@@ -60,7 +60,14 @@ distutils_do_install() { | |||
60 | fi | 60 | fi |
61 | 61 | ||
62 | rm -f ${D}${libdir}/${PYTHON_DIR}/site-packages/easy-install.pth | 62 | rm -f ${D}${libdir}/${PYTHON_DIR}/site-packages/easy-install.pth |
63 | 63 | ||
64 | # | ||
65 | # FIXME: Bandaid against wrong datadir computation | ||
66 | # | ||
67 | if test -e ${D}${datadir}/share; then | ||
68 | mv -f ${D}${datadir}/share/* ${D}${datadir}/ | ||
69 | fi | ||
70 | |||
64 | find ${D}${libdir}/${PYTHON_DIR}/site-packages -iname '*.pyo' -exec rm {} \; | 71 | find ${D}${libdir}/${PYTHON_DIR}/site-packages -iname '*.pyo' -exec rm {} \; |
65 | } | 72 | } |
66 | 73 | ||