diff options
author | Randy MacLeod <Randy.MacLeod@windriver.com> | 2021-08-10 13:52:19 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-08-26 22:09:43 +0100 |
commit | 61e1570c6a09c1984e919e8c0a82a74c1a08d821 (patch) | |
tree | accab4b08aa3c62f098c9bb19399efb46906256a /meta/classes/crate-fetch.bbclass | |
parent | 705b1d757fa221614f4f72cabf0fac5884cb6bfd (diff) | |
download | poky-61e1570c6a09c1984e919e8c0a82a74c1a08d821.tar.gz |
rust: initial merge of most of meta-rust
In the meta-rust repo at commit:
448047c Upgrade to 1.54.0 (#359)
Make the required directories:
mkdir ../oe-core/meta/recipes-devtools/rust
mkdir ../oe-core/meta/recipes-devtools/cargo
mkdir ../oe-core/meta/recipes-example
and then:
cp recipes-devtools/rust/* ../oe-core/meta/recipes-devtools/rust
cp recipes-devtools/cargo/* ../oe-core/meta/recipes-devtools/cargo
cp lib/crate.py ../oe-core/meta/lib
cp recipes-example/* ../oe-core/meta/recipes-example
cp conf/distro/include/rust_* ../oe-core/meta/conf/distro/include/
cp classes/* ../oe-core/meta/classes/
cp recipes-core/packagegroups/packagegroup-rust-cross-canadian.bb ../oe-core/meta/recipes-core/packagegroups
(From OE-Core rev: 3ed57578cca93ff1ba4e0bf3f25566e10659a2f9)
Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/crate-fetch.bbclass')
-rw-r--r-- | meta/classes/crate-fetch.bbclass | 13 |
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/classes/crate-fetch.bbclass b/meta/classes/crate-fetch.bbclass new file mode 100644 index 0000000000..c0ed434a96 --- /dev/null +++ b/meta/classes/crate-fetch.bbclass | |||
@@ -0,0 +1,13 @@ | |||
1 | # | ||
2 | # crate-fetch class | ||
3 | # | ||
4 | # Registers 'crate' method for Bitbake fetch2. | ||
5 | # | ||
6 | # Adds support for following format in recipe SRC_URI: | ||
7 | # crate://<packagename>/<version> | ||
8 | # | ||
9 | |||
10 | python () { | ||
11 | import crate | ||
12 | bb.fetch2.methods.append( crate.Crate() ) | ||
13 | } | ||