diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2013-12-04 18:32:43 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-12-05 14:25:27 +0000 |
commit | c295fe645303e51d4d4153ebb930b4fd98bcba0b (patch) | |
tree | ff25be56132203a388cd10d4c0598aa73b5269d4 /meta/classes/cpan-base.bbclass | |
parent | f750d65e15e4305e42e2d390fd741b1b0e6ad4fe (diff) | |
download | poky-c295fe645303e51d4d4153ebb930b4fd98bcba0b.tar.gz |
cpan-base: Add vardepvalue to get_perl_version function
* without this bitbake -S perf shows following error:
ERROR: Bitbake's cached basehash does not match the one we just generated
(/OE/oe-core/meta/recipes-kernel/perf/perf.bb.do_package)!
if you run it twice, once without perl in sysroot and once with perl
already built
(From OE-Core rev: f31f6a70ec24e8c9515d69c5092e15effc5e7d4d)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/cpan-base.bbclass')
-rw-r--r-- | meta/classes/cpan-base.bbclass | 3 |
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/classes/cpan-base.bbclass b/meta/classes/cpan-base.bbclass index 7e1e8d0d6b..aa502d5faa 100644 --- a/meta/classes/cpan-base.bbclass +++ b/meta/classes/cpan-base.bbclass | |||
@@ -10,6 +10,9 @@ RDEPENDS_${PN} += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" | |||
10 | PERL_OWN_DIR = "${@["", "/perl-native"][(bb.data.inherits_class('native', d))]}" | 10 | PERL_OWN_DIR = "${@["", "/perl-native"][(bb.data.inherits_class('native', d))]}" |
11 | 11 | ||
12 | # Determine the staged version of perl from the perl configuration file | 12 | # Determine the staged version of perl from the perl configuration file |
13 | # Assign vardepvalue, because otherwise signature is changed before and after | ||
14 | # perl is built (from None to real version in config.sh). | ||
15 | get_perl_version[vardepvalue] = "${PERL_OWN_DIR}" | ||
13 | def get_perl_version(d): | 16 | def get_perl_version(d): |
14 | import re | 17 | import re |
15 | cfg = d.expand('${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/config.sh') | 18 | cfg = d.expand('${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/config.sh') |