summaryrefslogtreecommitdiffstats
path: root/meta/classes/copyleft_compliance.bbclass
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2013-06-10 13:46:39 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-11 15:56:00 +0100
commit29f87014024ef2230e588169582247e063279c70 (patch)
tree0eb3f46a408988cff9088c51314f73474823da23 /meta/classes/copyleft_compliance.bbclass
parent9dba0ebb7b5af249f7735159306d6a4a5c0f4e51 (diff)
downloadpoky-29f87014024ef2230e588169582247e063279c70.tar.gz
copyleft_compliance: handle localpaths ending with '/'
(From OE-Core rev: 1f30d2eb2ef45550c71969c735275db1448b6ac6) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/copyleft_compliance.bbclass')
-rw-r--r--meta/classes/copyleft_compliance.bbclass2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/classes/copyleft_compliance.bbclass b/meta/classes/copyleft_compliance.bbclass
index 06b02278d3..adb48bed3b 100644
--- a/meta/classes/copyleft_compliance.bbclass
+++ b/meta/classes/copyleft_compliance.bbclass
@@ -39,6 +39,8 @@ python do_prepare_copyleft_sources () {
39 local = os.path.normpath(fetch.localpath(u.url)) 39 local = os.path.normpath(fetch.localpath(u.url))
40 if local.endswith('.bb'): 40 if local.endswith('.bb'):
41 continue 41 continue
42 elif local.endswith('/'):
43 local = local[:-1]
42 44
43 if u.mirrortarball: 45 if u.mirrortarball:
44 tarball_path = os.path.join(dl_dir, u.mirrortarball) 46 tarball_path = os.path.join(dl_dir, u.mirrortarball)