diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2016-10-12 10:33:47 +1300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-11-08 23:47:13 +0000 |
commit | b169435134fd1a2894ac179f386697874b109a0f (patch) | |
tree | 36d6904e1d072ea897c6d7fa1d310d0990dd4200 /meta/classes/cmake.bbclass | |
parent | 95e3d7108062fa5aa6db3670d22940a4b9513f6b (diff) | |
download | poky-b169435134fd1a2894ac179f386697874b109a0f.tar.gz |
classes/externalsrc: re-run do_configure when configure files change
If the user modifies files such as CMakeLists.txt in the case of cmake,
we want do_configure to re-run so that those changes can take effect. In
order to accomplish that, have a variable CONFIGURE_FILES which
specifies a list of files that will be put into do_configure's checksum
(either full paths, or just filenames which will be searched for in the
entire source tree). CONFIGURE_FILES then just needs to be set
appropriately depending on what do_configure is doing; for now I've set
this for autotools and cmake which are the most common cases.
Fixes [YOCTO #7617].
(From OE-Core rev: 923fc20c2862a6d75f949082c9f6532ab7e2d2cd)
(From OE-Core rev: 4019bb8454c36c4baf1d4f23e2d4fafb6c47fbc0)
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/cmake.bbclass')
-rw-r--r-- | meta/classes/cmake.bbclass | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/classes/cmake.bbclass b/meta/classes/cmake.bbclass index 77ab626f9f..feabf6dea9 100644 --- a/meta/classes/cmake.bbclass +++ b/meta/classes/cmake.bbclass | |||
@@ -84,6 +84,8 @@ EOF | |||
84 | 84 | ||
85 | addtask generate_toolchain_file after do_patch before do_configure | 85 | addtask generate_toolchain_file after do_patch before do_configure |
86 | 86 | ||
87 | CONFIGURE_FILES = "CMakeLists.txt" | ||
88 | |||
87 | cmake_do_configure() { | 89 | cmake_do_configure() { |
88 | if [ "${OECMAKE_BUILDPATH}" ]; then | 90 | if [ "${OECMAKE_BUILDPATH}" ]; then |
89 | bbnote "cmake.bbclass no longer uses OECMAKE_BUILDPATH. The default behaviour is now out-of-tree builds with B=WORKDIR/build." | 91 | bbnote "cmake.bbclass no longer uses OECMAKE_BUILDPATH. The default behaviour is now out-of-tree builds with B=WORKDIR/build." |