summaryrefslogtreecommitdiffstats
path: root/meta/classes/binconfig-disabled.bbclass
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2015-01-23 06:48:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-29 15:36:49 +0000
commitb2b62c3608b424cfc3e83bca372d508c55e42038 (patch)
tree825d414be390851abcb9a9d0af31c5817d0e3bc0 /meta/classes/binconfig-disabled.bbclass
parent5e6e95d71be1486c58d979ace744656a182feba2 (diff)
downloadpoky-b2b62c3608b424cfc3e83bca372d508c55e42038.tar.gz
binconfig-disabled: install config scripts in sysroot
The purpose of binconfig-disabled is to manipulate config scripts such that using them causes errors. But that only works when the modified config script really gets installed in the sysroot. That is not the case with the staging code in binconfig.bbclass. Only patched config files get staged. For that reason it seemed more appropriate to change binconfig-disabled instead of binconfig. The reason for the change was the observation that the swig recipe needs pcre-config installed on the host system. Staging pcre-config removes that host dependency. swig did not actually end up *using* the pcre-config from the host, because later during do_compile the patched configure.ac is used to re-generate configure. (From OE-Core rev: 822df6d23c9c24e131c38fda9f0012c47ad7af46) Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/binconfig-disabled.bbclass')
-rw-r--r--meta/classes/binconfig-disabled.bbclass10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/classes/binconfig-disabled.bbclass b/meta/classes/binconfig-disabled.bbclass
index 4c42ae22e4..0acc9648b0 100644
--- a/meta/classes/binconfig-disabled.bbclass
+++ b/meta/classes/binconfig-disabled.bbclass
@@ -16,3 +16,13 @@ do_install_append () {
16 echo "exit 1" >> ${D}$x 16 echo "exit 1" >> ${D}$x
17 done 17 done
18} 18}
19
20SYSROOT_PREPROCESS_FUNCS += "binconfig_disabled_sysroot_preprocess"
21
22binconfig_disabled_sysroot_preprocess () {
23 for x in ${BINCONFIG}; do
24 configname=`basename $x`
25 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}
26 install ${D}$x ${SYSROOT_DESTDIR}${bindir_crossscripts}
27 done
28}