diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2011-11-11 17:28:43 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-11-16 17:19:13 +0000 |
commit | 88f4568fc55998266b6d60d610bf9039c26c4b51 (patch) | |
tree | a2408c2f27ecf4dcd32a9937e2fd9ad00d26ba75 /meta/classes/base.bbclass | |
parent | 8daf4546764143ef3b8b6a9b773da65290d0708e (diff) | |
download | poky-88f4568fc55998266b6d60d610bf9039c26c4b51.tar.gz |
base.bbclass: add subversion-native to DEPENDS if there is svn:// in SRC_URI
* in some cases this could cause circual dependency (ie if we decide to
apr_svn.bb or something like that before subversion-native in dependency
tree), Saul said he had such case, but I wasn't able to reproduce it
here (here it builds subversion-native-1.7.0 fine).
(From OE-Core rev: 820bb7f4a0ced61ae62886bc7c5168151db919ea)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/base.bbclass')
-rw-r--r-- | meta/classes/base.bbclass | 8 |
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/classes/base.bbclass b/meta/classes/base.bbclass index f3f798f9bf..ba1f230ced 100644 --- a/meta/classes/base.bbclass +++ b/meta/classes/base.bbclass | |||
@@ -401,8 +401,14 @@ python () { | |||
401 | bb.note("SKIPPING %s because it's %s" % (pn, this_license)) | 401 | bb.note("SKIPPING %s because it's %s" % (pn, this_license)) |
402 | raise bb.parse.SkipPackage("incompatible with license %s" % this_license) | 402 | raise bb.parse.SkipPackage("incompatible with license %s" % this_license) |
403 | 403 | ||
404 | # Git packages should DEPEND on git-native | ||
405 | srcuri = d.getVar('SRC_URI', 1) | 404 | srcuri = d.getVar('SRC_URI', 1) |
405 | # Svn packages should DEPEND on subversion-native | ||
406 | if "svn://" in srcuri: | ||
407 | depends = d.getVarFlag('do_fetch', 'depends') or "" | ||
408 | depends = depends + " subversion-native:do_populate_sysroot" | ||
409 | d.setVarFlag('do_fetch', 'depends', depends) | ||
410 | |||
411 | # Git packages should DEPEND on git-native | ||
406 | if "git://" in srcuri: | 412 | if "git://" in srcuri: |
407 | depends = d.getVarFlag('do_fetch', 'depends') or "" | 413 | depends = d.getVarFlag('do_fetch', 'depends') or "" |
408 | depends = depends + " git-native:do_populate_sysroot" | 414 | depends = depends + " git-native:do_populate_sysroot" |