diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2015-07-30 08:18:09 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-08-01 22:24:15 +0100 |
commit | 1df8af4248250b9bdbde3b15a00933cf49dd1356 (patch) | |
tree | d0745e10843c38b9c1e385b0156360a5dcd733d5 /meta/classes/base.bbclass | |
parent | 6087a04cb8c5356e782628683bec4f2ef6ec1909 (diff) | |
download | poky-1df8af4248250b9bdbde3b15a00933cf49dd1356.tar.gz |
base.bbclass: move invalid PACKAGECONFIG checking to insane.bbclass
There was a problem when check invalid PACKAGECONFIG in the anonymous
function (when parsing), for example, there are two versions of a
recipe:
foo_1.0.bb
foo_2.0.bb
While foo_2.0.bb has a "PACKAGECONFIG[item] = 'x,y,z'", but foo_1.0.bb
doesn't, if we set PACKAGECONFIG_pn-foo = "item" in a conf file, we
would get the warning about invalid PACKAGECONFIG for foo_1.0.bb. Delay
the checking to build time will fix the problem.
[YOCTO #8065]
(From OE-Core rev: 0a64dfcdb9f5a37771f881895be230392c4d0aff)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/base.bbclass')
-rw-r--r-- | meta/classes/base.bbclass | 4 |
1 files changed, 0 insertions, 4 deletions
diff --git a/meta/classes/base.bbclass b/meta/classes/base.bbclass index 531b0e72c0..f0780011bd 100644 --- a/meta/classes/base.bbclass +++ b/meta/classes/base.bbclass | |||
@@ -353,10 +353,6 @@ python () { | |||
353 | pkgconfig = (d.getVar('PACKAGECONFIG', True) or "").split() | 353 | pkgconfig = (d.getVar('PACKAGECONFIG', True) or "").split() |
354 | pn = d.getVar("PN", True) | 354 | pn = d.getVar("PN", True) |
355 | 355 | ||
356 | for pconfig in pkgconfig: | ||
357 | if pconfig not in pkgconfigflags: | ||
358 | bb.warn("%s: invalid PACKAGECONFIG: %s" % (pn, pconfig)) | ||
359 | |||
360 | mlprefix = d.getVar("MLPREFIX", True) | 356 | mlprefix = d.getVar("MLPREFIX", True) |
361 | 357 | ||
362 | def expandFilter(appends, extension, prefix): | 358 | def expandFilter(appends, extension, prefix): |