diff options
author | Joshua Lock <joshua.g.lock@intel.com> | 2016-12-14 21:13:04 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-12-16 10:23:23 +0000 |
commit | c4e2c59088765d1f1de7ec57cde91980f887c2ff (patch) | |
tree | a2fda8ac5916fb59a711e9220c2177008cca9347 /meta/classes/autotools.bbclass | |
parent | d5e67725ac11e3296cad104470931ffa16824b90 (diff) | |
download | poky-c4e2c59088765d1f1de7ec57cde91980f887c2ff.tar.gz |
meta: remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True
option from getVar() calls with a regex search and replace.
Search made with the following regex: getVar ?\(( ?[^,()]*), True\)
(From OE-Core rev: 7c552996597faaee2fbee185b250c0ee30ea3b5f)
Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r-- | meta/classes/autotools.bbclass | 12 |
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass index c43ea9a7ef..c43531b050 100644 --- a/meta/classes/autotools.bbclass +++ b/meta/classes/autotools.bbclass | |||
@@ -1,8 +1,8 @@ | |||
1 | def autotools_dep_prepend(d): | 1 | def autotools_dep_prepend(d): |
2 | if d.getVar('INHIBIT_AUTOTOOLS_DEPS', True): | 2 | if d.getVar('INHIBIT_AUTOTOOLS_DEPS'): |
3 | return '' | 3 | return '' |
4 | 4 | ||
5 | pn = d.getVar('PN', True) | 5 | pn = d.getVar('PN') |
6 | deps = '' | 6 | deps = '' |
7 | 7 | ||
8 | if pn in ['autoconf-native', 'automake-native', 'help2man-native']: | 8 | if pn in ['autoconf-native', 'automake-native', 'help2man-native']: |
@@ -14,7 +14,7 @@ def autotools_dep_prepend(d): | |||
14 | if not bb.data.inherits_class('native', d) \ | 14 | if not bb.data.inherits_class('native', d) \ |
15 | and not bb.data.inherits_class('nativesdk', d) \ | 15 | and not bb.data.inherits_class('nativesdk', d) \ |
16 | and not bb.data.inherits_class('cross', d) \ | 16 | and not bb.data.inherits_class('cross', d) \ |
17 | and not d.getVar('INHIBIT_DEFAULT_DEPS', True): | 17 | and not d.getVar('INHIBIT_DEFAULT_DEPS'): |
18 | deps += 'libtool-cross ' | 18 | deps += 'libtool-cross ' |
19 | 19 | ||
20 | return deps + 'gnu-config-native ' | 20 | return deps + 'gnu-config-native ' |
@@ -139,15 +139,15 @@ ACLOCALDIR = "${WORKDIR}/aclocal-copy" | |||
139 | python autotools_copy_aclocals () { | 139 | python autotools_copy_aclocals () { |
140 | import copy | 140 | import copy |
141 | 141 | ||
142 | s = d.getVar("AUTOTOOLS_SCRIPT_PATH", True) | 142 | s = d.getVar("AUTOTOOLS_SCRIPT_PATH") |
143 | if not os.path.exists(s + "/configure.in") and not os.path.exists(s + "/configure.ac"): | 143 | if not os.path.exists(s + "/configure.in") and not os.path.exists(s + "/configure.ac"): |
144 | if not d.getVar("AUTOTOOLS_COPYACLOCAL", False): | 144 | if not d.getVar("AUTOTOOLS_COPYACLOCAL", False): |
145 | return | 145 | return |
146 | 146 | ||
147 | taskdepdata = d.getVar("BB_TASKDEPDATA", False) | 147 | taskdepdata = d.getVar("BB_TASKDEPDATA", False) |
148 | #bb.warn(str(taskdepdata)) | 148 | #bb.warn(str(taskdepdata)) |
149 | pn = d.getVar("PN", True) | 149 | pn = d.getVar("PN") |
150 | aclocaldir = d.getVar("ACLOCALDIR", True) | 150 | aclocaldir = d.getVar("ACLOCALDIR") |
151 | oe.path.remove(aclocaldir) | 151 | oe.path.remove(aclocaldir) |
152 | bb.utils.mkdirhier(aclocaldir) | 152 | bb.utils.mkdirhier(aclocaldir) |
153 | start = None | 153 | start = None |