diff options
author | Robert P. J. Day <rpjday@crashcourse.ca> | 2017-03-26 06:24:07 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-27 11:08:34 +0100 |
commit | 6b210e74b7f7d622c95428210fc641788af29266 (patch) | |
tree | 06cd51ee9bfb552254f8d4ae62a572abc23238d1 /meta/classes/autotools.bbclass | |
parent | 7ddcbc5eca0c09408bc3698561f8b913682232d4 (diff) | |
download | poky-6b210e74b7f7d622c95428210fc641788af29266.tar.gz |
autotools.bbclass: Replace "grep ... >/dev/null" with "grep -q"
For aesthetic style reasons, use "grep -q" instead of ">/dev/null".
(From OE-Core rev: 39a7bfde92211b3546ff0a8e6a3e549714996b28)
Signed-off-by: Robert P. J. Day <rpjday@crashcourse.ca>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r-- | meta/classes/autotools.bbclass | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass index d49473440e..ac04a07cb5 100644 --- a/meta/classes/autotools.bbclass +++ b/meta/classes/autotools.bbclass | |||
@@ -193,14 +193,14 @@ autotools_do_configure() { | |||
193 | else | 193 | else |
194 | CONFIGURE_AC=configure.ac | 194 | CONFIGURE_AC=configure.ac |
195 | fi | 195 | fi |
196 | if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then | 196 | if grep -q "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC; then |
197 | if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then | 197 | if grep -q "sed.*POTFILES" $CONFIGURE_AC; then |
198 | : do nothing -- we still have an old unmodified configure.ac | 198 | : do nothing -- we still have an old unmodified configure.ac |
199 | else | 199 | else |
200 | bbnote Executing glib-gettextize --force --copy | 200 | bbnote Executing glib-gettextize --force --copy |
201 | echo "no" | glib-gettextize --force --copy | 201 | echo "no" | glib-gettextize --force --copy |
202 | fi | 202 | fi |
203 | elif grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then | 203 | elif grep -q "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC; then |
204 | # We'd call gettextize here if it wasn't so broken... | 204 | # We'd call gettextize here if it wasn't so broken... |
205 | cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/ | 205 | cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/ |
206 | if [ -d ${S}/po/ ]; then | 206 | if [ -d ${S}/po/ ]; then |
@@ -212,7 +212,7 @@ autotools_do_configure() { | |||
212 | PRUNE_M4="$PRUNE_M4 gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4" | 212 | PRUNE_M4="$PRUNE_M4 gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4" |
213 | fi | 213 | fi |
214 | mkdir -p m4 | 214 | mkdir -p m4 |
215 | if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then | 215 | if grep -q "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC; then |
216 | if ! echo "${DEPENDS}" | grep -q intltool-native; then | 216 | if ! echo "${DEPENDS}" | grep -q intltool-native; then |
217 | bbwarn "Missing DEPENDS on intltool-native" | 217 | bbwarn "Missing DEPENDS on intltool-native" |
218 | fi | 218 | fi |