diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2016-10-12 10:33:47 +1300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-10-11 23:04:44 +0100 |
commit | f7259298a29e865dc03bde77e4617bc671a9c85e (patch) | |
tree | f219761c8106468283a07fd2ca58c6e23939af94 /meta/classes/autotools.bbclass | |
parent | 2d60ffcbdadb689767ff3291f6b933d72b569b4b (diff) | |
download | poky-f7259298a29e865dc03bde77e4617bc671a9c85e.tar.gz |
classes/externalsrc: re-run do_configure when configure files change
If the user modifies files such as CMakeLists.txt in the case of cmake,
we want do_configure to re-run so that those changes can take effect. In
order to accomplish that, have a variable CONFIGURE_FILES which
specifies a list of files that will be put into do_configure's checksum
(either full paths, or just filenames which will be searched for in the
entire source tree). CONFIGURE_FILES then just needs to be set
appropriately depending on what do_configure is doing; for now I've set
this for autotools and cmake which are the most common cases.
Fixes [YOCTO #7617].
(From OE-Core rev: 923fc20c2862a6d75f949082c9f6532ab7e2d2cd)
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r-- | meta/classes/autotools.bbclass | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass index ecbba9f603..c43ea9a7ef 100644 --- a/meta/classes/autotools.bbclass +++ b/meta/classes/autotools.bbclass | |||
@@ -259,6 +259,8 @@ python autotools_copy_aclocals () { | |||
259 | } | 259 | } |
260 | autotools_copy_aclocals[vardepsexclude] += "MACHINE SDK_ARCH BUILD_ARCH SDK_OS BB_TASKDEPDATA" | 260 | autotools_copy_aclocals[vardepsexclude] += "MACHINE SDK_ARCH BUILD_ARCH SDK_OS BB_TASKDEPDATA" |
261 | 261 | ||
262 | CONFIGURE_FILES = "${S}/configure.in ${S}/configure.ac ${S}/config.h.in ${S}/acinclude.m4 Makefile.am" | ||
263 | |||
262 | autotools_do_configure() { | 264 | autotools_do_configure() { |
263 | # WARNING: gross hack follows: | 265 | # WARNING: gross hack follows: |
264 | # An autotools built package generally needs these scripts, however only | 266 | # An autotools built package generally needs these scripts, however only |