summaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-04-28 21:49:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-04 00:54:37 +0100
commitfc934af7c843a899f41d43fdb239d255da777903 (patch)
treeb3a9391af053141103455de4661f059e91bea035 /meta/classes/autotools.bbclass
parent0e2eb05f46192e179912160cc557f274148dcf15 (diff)
downloadpoky-fc934af7c843a899f41d43fdb239d255da777903.tar.gz
logging: update existing oe* logging users to the bb* interface
The new bash logging class provides bbnote, bbwarn, bbfatal, and bbdebug replacements (as well as bbplain and bberror) for the oe* equivalents. Use the new bb* API in preparation to delete the oe* logging API. This patch was automatically generated by a sed script. The result has been visually inspected and used to build core-image-sato for qemux86. (From OE-Core rev: a1f09fce5caba389d0484b169f0cde85d64514fa) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index cbd2e9666e..27f4a01f12 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -70,10 +70,10 @@ oe_runconf () {
70 if [ -x ${S}/configure ] ; then 70 if [ -x ${S}/configure ] ; then
71 cfgcmd="${S}/configure \ 71 cfgcmd="${S}/configure \
72 ${CONFIGUREOPTS} ${EXTRA_OECONF} $@" 72 ${CONFIGUREOPTS} ${EXTRA_OECONF} $@"
73 oenote "Running $cfgcmd..." 73 bbnote "Running $cfgcmd..."
74 $cfgcmd || oefatal "oe_runconf failed" 74 $cfgcmd || bbfatal "oe_runconf failed"
75 else 75 else
76 oefatal "no configure script found" 76 bbfatal "no configure script found"
77 fi 77 fi
78} 78}
79 79
@@ -132,7 +132,7 @@ autotools_do_configure() {
132 if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then 132 if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
133 : do nothing -- we still have an old unmodified configure.ac 133 : do nothing -- we still have an old unmodified configure.ac
134 else 134 else
135 oenote Executing glib-gettextize --force --copy 135 bbnote Executing glib-gettextize --force --copy
136 echo "no" | glib-gettextize --force --copy 136 echo "no" | glib-gettextize --force --copy
137 fi 137 fi
138 else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then 138 else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
@@ -142,11 +142,11 @@ autotools_do_configure() {
142 fi 142 fi
143 mkdir -p m4 143 mkdir -p m4
144 if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then 144 if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
145 oenote Executing intltoolize --copy --force --automake 145 bbnote Executing intltoolize --copy --force --automake
146 intltoolize --copy --force --automake 146 intltoolize --copy --force --automake
147 fi 147 fi
148 oenote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths 148 bbnote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
149 autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed." 149 autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || bbfatal "autoreconf execution failed."
150 cd $olddir 150 cd $olddir
151 fi 151 fi
152 ;; 152 ;;
@@ -154,7 +154,7 @@ autotools_do_configure() {
154 if [ -e ${S}/configure ]; then 154 if [ -e ${S}/configure ]; then
155 oe_runconf 155 oe_runconf
156 else 156 else
157 oenote "nothing to configure" 157 bbnote "nothing to configure"
158 fi 158 fi
159} 159}
160 160