summaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2012-02-10 19:00:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-23 23:59:35 +0000
commita470400cf8455d9f6f16905bfae59a3511ae5d4c (patch)
tree249c1fb81ded78b8d04e350c98678865b7fd2609 /meta/classes/autotools.bbclass
parenta6fb1939c132986a859fe8d2a876919d82683eea (diff)
downloadpoky-a470400cf8455d9f6f16905bfae59a3511ae5d4c.tar.gz
autotools.bbclass: Don't copy into non-existant directory
* If configure.ac contains AM_GNU_GETTEXT and po/Makefile.in.in doesn't exist, autotools_do_configure() copies a local version of Makefile.in.in to this location. If the directory 'po' doesn't exist, the function aborts. * This patch verifies that the directory exists before copying a file to it. This fixes libcddb, which uses AM_GNU_GETTEXT, but has no 'po' directory. (From OE-Core rev: ba175bdfe85d701298d28e5190e55207420a24e8) Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 5d743338fc..e22ea6837f 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -149,7 +149,7 @@ autotools_do_configure() {
149 else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then 149 else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
150 # We'd call gettextize here if it wasn't so broken... 150 # We'd call gettextize here if it wasn't so broken...
151 cp ${STAGING_DATADIR}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/ 151 cp ${STAGING_DATADIR}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
152 if [ ! -e ${S}/po/Makefile.in.in ]; then 152 if [ -d ${S}/po/ -a ! -e ${S}/po/Makefile.in.in ]; then
153 cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/po/ 153 cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/po/
154 fi 154 fi
155 fi 155 fi