summaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 14:24:35 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-14 13:18:05 +0100
commit5405efae327565fb891e93dfb0de0944fef91362 (patch)
treee27a14729c728f6daa683a07957e55a1954c8c07 /meta/classes/autotools.bbclass
parent667f4ebc6f8a506c452c0bb9b62ac832c4d69f3e (diff)
downloadpoky-5405efae327565fb891e93dfb0de0944fef91362.tar.gz
autotools: Enhance gettext handling to better work with SCM versions of code
If we pull SCM based code using gettext, Makefile.in.in in the po directory can be missing. We therefore need to add this if its not already present. We could use gettextize if it wasn't so broken (for example requiring user input on stdin and installing way more files that we ever care about such as the m4 files). We also have a problem if a recipe sets a different AUX dir, for now fix this by allowing recipes to specify when this is being done using the AUTOTOOLS_AUXDIR variable. Ultimately we could likely figure this out automatically. (From OE-Core rev: acaefad1aa4b45813a004e0cd1d85bc013e435f4) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index a4ce8519d5..041332208e 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -80,6 +80,8 @@ oe_runconf () {
80 fi 80 fi
81} 81}
82 82
83AUTOTOOLS_AUXDIR ?= "${S}"
84
83autotools_do_configure() { 85autotools_do_configure() {
84 case ${PN} in 86 case ${PN} in
85 autoconf*) 87 autoconf*)
@@ -144,7 +146,11 @@ autotools_do_configure() {
144 echo "no" | glib-gettextize --force --copy 146 echo "no" | glib-gettextize --force --copy
145 fi 147 fi
146 else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then 148 else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
147 cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/ 149 # We'd call gettextize here if it wasn't so broken...
150 cp ${STAGING_DATADIR}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
151 if [ ! -e ${S}/po/Makefile.in.in ]; then
152 cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/po/
153 fi
148 fi 154 fi
149 fi 155 fi
150 fi 156 fi