summaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-04-24 18:38:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-28 10:45:43 +0100
commit34e8e9e28587498c7907b01ea5623253a5ced9ef (patch)
treea7fdd192fc8c5c0adab03ae9f5f8bd306f32fd96 /meta/classes/autotools.bbclass
parent01102bd2d281e1906b339321091c701904a7cf17 (diff)
downloadpoky-34e8e9e28587498c7907b01ea5623253a5ced9ef.tar.gz
autotools.bbclass: Copy gettext files only if --disable-nls is not set
(From OE-Core rev: 040d4dea9637a4723cbb2a74975130d3b86e569a) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass19
1 files changed, 10 insertions, 9 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 7ebf833603..cbd2e9666e 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -127,17 +127,18 @@ autotools_do_configure() {
127 else 127 else
128 CONFIGURE_AC=configure.ac 128 CONFIGURE_AC=configure.ac
129 fi 129 fi
130 if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then 130 if ! echo ${EXTRA_OECONF} | grep -q "\-\-disable-nls"; then
131 if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then 131 if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
132 : do nothing -- we still have an old unmodified configure.ac 132 if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
133 else 133 : do nothing -- we still have an old unmodified configure.ac
134 oenote Executing glib-gettextize --force --copy 134 else
135 echo "no" | glib-gettextize --force --copy 135 oenote Executing glib-gettextize --force --copy
136 echo "no" | glib-gettextize --force --copy
137 fi
138 else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
139 cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
136 fi 140 fi
137 else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
138 cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
139 fi 141 fi
140
141 fi 142 fi
142 mkdir -p m4 143 mkdir -p m4
143 if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then 144 if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then