diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-07-18 13:08:48 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-07-19 12:24:50 +0100 |
commit | 73cf0335c463758379765fa5f26a4484afaca8a0 (patch) | |
tree | eed499207c71f925dfad21d1c4e58cbb1ec22d53 /meta/classes/archiver.bbclass | |
parent | 7b2c67874e03bc378c6def5cf1558238134e1b61 (diff) | |
download | poky-73cf0335c463758379765fa5f26a4484afaca8a0.tar.gz |
Remove a number of unneeded import os/bb calls
The bb and os modules are always imported so having these extra import calls
are a waste of space/execution time. They also set a bad example for people
copy and pasting code so clean them up.
(From OE-Core rev: 7d674820958be3a7051ea619effe1a6061d9cbe2)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/archiver.bbclass')
-rw-r--r-- | meta/classes/archiver.bbclass | 3 |
1 files changed, 0 insertions, 3 deletions
diff --git a/meta/classes/archiver.bbclass b/meta/classes/archiver.bbclass index 2b5404f1da..8e97e447c9 100644 --- a/meta/classes/archiver.bbclass +++ b/meta/classes/archiver.bbclass | |||
@@ -76,7 +76,6 @@ def tar_filter(d): | |||
76 | def get_bb_inc(d): | 76 | def get_bb_inc(d): |
77 | '''create a directory "script-logs" including .bb and .inc file in ${WORKDIR}''' | 77 | '''create a directory "script-logs" including .bb and .inc file in ${WORKDIR}''' |
78 | import re | 78 | import re |
79 | import os | ||
80 | import shutil | 79 | import shutil |
81 | 80 | ||
82 | bbinc = [] | 81 | bbinc = [] |
@@ -154,7 +153,6 @@ def get_series(d): | |||
154 | 153 | ||
155 | def get_applying_patches(d): | 154 | def get_applying_patches(d): |
156 | """only copy applying patches to a pointed directory which will be archived to tarball""" | 155 | """only copy applying patches to a pointed directory which will be archived to tarball""" |
157 | import os | ||
158 | import shutil | 156 | import shutil |
159 | 157 | ||
160 | 158 | ||
@@ -174,7 +172,6 @@ def get_applying_patches(d): | |||
174 | 172 | ||
175 | def not_tarball(d): | 173 | def not_tarball(d): |
176 | '''packages including key words 'work-shared','native', 'task-' will be passed''' | 174 | '''packages including key words 'work-shared','native', 'task-' will be passed''' |
177 | import os | ||
178 | 175 | ||
179 | workdir = d.getVar('WORKDIR',True) | 176 | workdir = d.getVar('WORKDIR',True) |
180 | s = d.getVar('S',True) | 177 | s = d.getVar('S',True) |