diff options
author | Xiaofeng Yan <xiaofeng.yan@windriver.com> | 2012-03-26 18:49:29 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-03-26 23:13:20 +0100 |
commit | 0cc11b390d1fbd322fd1ce5ed5a9cfea5839f58a (patch) | |
tree | b90a932a12944cb3396c70155e25aabe6f85fd17 /meta/classes/archive-original-source.bbclass | |
parent | 6dd4ddf7eacc0b71f046a3086d949830918bc4c3 (diff) | |
download | poky-0cc11b390d1fbd322fd1ce5ed5a9cfea5839f58a.tar.gz |
archive-original-source.bbclass: Archive original source
This bbclass prepares for archiving original source.
If original source is tarball, then copy this tarball to
${DEPLOY_DIR}/sources.
If original source is dirctory, then archive this directory to
tarball
[YOCTO #1977]
(From OE-Core rev: bc18dfdf42c8ece353a580671502ad79d37fa476)
Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/archive-original-source.bbclass')
-rw-r--r-- | meta/classes/archive-original-source.bbclass | 14 |
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/classes/archive-original-source.bbclass b/meta/classes/archive-original-source.bbclass new file mode 100644 index 0000000000..b08553365c --- /dev/null +++ b/meta/classes/archive-original-source.bbclass | |||
@@ -0,0 +1,14 @@ | |||
1 | # This file is for getting archiving packages with original sources(archive 's' after unpack stage),patches,logs(archive 'temp' after package_write_rpm),dump data and | ||
2 | # creating diff file(get all environment variables and functions in building and mapping all content in 's' including patches to xxx.diff.gz. | ||
3 | # All archived packages will be deployed in ${DEPLOY_DIR}/sources | ||
4 | |||
5 | inherit archiver | ||
6 | |||
7 | # Get original sources archiving package with patches | ||
8 | do_unpack[postfuncs] += "do_archive_original_sources_patches " | ||
9 | |||
10 | # Get archiving package with temp(logs) and scripts(.bb and inc files) | ||
11 | do_package_write_rpm[prefuncs] += "do_archive_scripts_logs " | ||
12 | |||
13 | # Get dump date and create diff file | ||
14 | do_package_write_rpm[postfuncs] += "do_dumpdata_create_diff_gz " | ||