diff options
author | Constantin Musca <constantinx.musca@intel.com> | 2012-12-10 11:07:59 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-12-13 16:54:35 +0000 |
commit | a0a265e352b074b54928cf50563561c92aa2f814 (patch) | |
tree | 9075b248c443522aeb5dada91b22cc61bf0ee2dd /meta-yocto | |
parent | 0be41d6e30e6dfd9d77e7b8b7ca11ab0b8474cbb (diff) | |
download | poky-a0a265e352b074b54928cf50563561c92aa2f814.tar.gz |
poky-tiny.conf: blacklist inappropriate image options
Blacklist all images that fail when using poky-tiny
poky-tiny image tests:
1. build-appliance-image
* ERROR: Nothing RPROVIDES libx11-dev
2. core-image-minimal-*
* ok
3. core-image-base
* libcap fails at do_compile
4. core-image-basic
* libcap fails at do_compile
5. core-image-clutter
* ERROR: Nothing PROVIDES virtual/libx11
6. core-image-gtk-directfb
* ERROR: Nothing RPROVIDES libxt
7. core-image-lsb, core-image-lsb-dev, core-image-lsb-sdk
* ERROR: Nothing RPROVIDES libxt
8. core-image-rt
* ERROR: Multiple .bb files are due to be built which each provide virtual/kernel
(/home/dev/yocto/poky/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
/home/dev/yocto/poky/meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb).
9. core-image-rt-sdk
* ERROR: Nothing PROVIDES xext
10. core-image-sato, core-image-sato-dev, core-image-sato-sdk
* ERROR: Nothing PROVIDES libxft
11. core-image-x11
* ERROR: Nothing PROVIDES virtual/libx11
12. q4te-demo-image
* libcap fails at do_compile
[YOCTO #2565]
(From meta-yocto rev: 6b6d84b6652f57ea8dd37e6921c280d30ef04b93)
Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto')
-rw-r--r-- | meta-yocto/conf/distro/poky-tiny.conf | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-yocto/conf/distro/poky-tiny.conf b/meta-yocto/conf/distro/poky-tiny.conf index d40748e174..9197a7c1d5 100644 --- a/meta-yocto/conf/distro/poky-tiny.conf +++ b/meta-yocto/conf/distro/poky-tiny.conf | |||
@@ -120,3 +120,20 @@ MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "" | |||
120 | # will build perl in case this package is installed. Since we don't care about | 120 | # will build perl in case this package is installed. Since we don't care about |
121 | # this script for the purposes of tiny, remove the dependency from here. | 121 | # this script for the purposes of tiny, remove the dependency from here. |
122 | RDEPENDS_${PN}-mtrace_pn-eglibc = "" | 122 | RDEPENDS_${PN}-mtrace_pn-eglibc = "" |
123 | |||
124 | INHERIT += "blacklist" | ||
125 | PNBLACKLIST[build-appliance-image] = "not buildable with poky-tiny" | ||
126 | PNBLACKLIST[core-image-base] = "not buildable with poky-tiny" | ||
127 | PNBLACKLIST[core-image-basic] = "not buildable with poky-tiny" | ||
128 | PNBLACKLIST[core-image-clutter] = "not buildable with poky-tiny" | ||
129 | PNBLACKLIST[core-image-gtk-directfb] = "not buildable with poky-tiny" | ||
130 | PNBLACKLIST[core-image-lsb] = "not buildable with poky-tiny" | ||
131 | PNBLACKLIST[core-image-lsb-dev] = "not buildable with poky-tiny" | ||
132 | PNBLACKLIST[core-image-lsb-sdk] = "not buildable with poky-tiny" | ||
133 | PNBLACKLIST[core-image-rt] = "not buildable with poky-tiny" | ||
134 | PNBLACKLIST[core-image-rt-sdk] = "not buildable with poky-tiny" | ||
135 | PNBLACKLIST[core-image-sato] = "not buildable with poky-tiny" | ||
136 | PNBLACKLIST[core-image-sato-dev] = "not buildable with poky-tiny" | ||
137 | PNBLACKLIST[core-image-sato-sdk] = "not buildable with poky-tiny" | ||
138 | PNBLACKLIST[core-image-x11] = "not buildable with poky-tiny" | ||
139 | PNBLACKLIST[qt4e-demo-image] = "not buildable with poky-tiny" | ||