diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2012-05-23 22:45:58 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-06-08 11:57:50 +0100 |
commit | 5010afd2e0bedb8a365991a4e19389edc93978c2 (patch) | |
tree | 09b80f695678dde3b32691981f2bd4d3447775b2 /meta-yocto | |
parent | b6ceefc36e87bedce8217c6a9d3d1af20c6f703b (diff) | |
download | poky-5010afd2e0bedb8a365991a4e19389edc93978c2.tar.gz |
linux-yocto/meta-yocto: add machine aliases for yocto BSPs
To avoid mapping machine names to kernel machine names in recipes,
we can define multiple KMACHINE names for a single in tree board.
This allows the tools to match a board description to multiple
different MACHINEs.
As a result, we can remove the explicit KMACHINE mappings from
the linux-yocto recipes and allow the KMACHINE=${MACHINE} default
to handle mappings. Individual recipes an bbappends can override
this as required.
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-yocto')
-rw-r--r-- | meta-yocto/recipes-kernel/linux/linux-yocto_3.0.bbappend | 3 | ||||
-rw-r--r-- | meta-yocto/recipes-kernel/linux/linux-yocto_3.2.bbappend | 5 |
2 files changed, 0 insertions, 8 deletions
diff --git a/meta-yocto/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-yocto/recipes-kernel/linux/linux-yocto_3.0.bbappend index 2313034b54..d0608bc0fe 100644 --- a/meta-yocto/recipes-kernel/linux/linux-yocto_3.0.bbappend +++ b/meta-yocto/recipes-kernel/linux/linux-yocto_3.0.bbappend | |||
@@ -3,9 +3,6 @@ KBRANCH_routerstationpro = "yocto/standard/routerstationpro" | |||
3 | KBRANCH_mpc8315e-rdb = "yocto/standard/fsl-mpc8315e-rdb" | 3 | KBRANCH_mpc8315e-rdb = "yocto/standard/fsl-mpc8315e-rdb" |
4 | KBRANCH_beagleboard = "yocto/standard/beagleboard" | 4 | KBRANCH_beagleboard = "yocto/standard/beagleboard" |
5 | 5 | ||
6 | # temporary until 3.0 tree is updated to have machine mapping | ||
7 | KMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb" | ||
8 | |||
9 | SRCREV_machine_atom-pc ?= "45d64709c00fce6e9b76a638c4ca6f30a8e9d25a" | 6 | SRCREV_machine_atom-pc ?= "45d64709c00fce6e9b76a638c4ca6f30a8e9d25a" |
10 | SRCREV_machine_routerstationpro ?= "21bd4a0a3b0f061e4640dd1011ebc94d122b5e40" | 7 | SRCREV_machine_routerstationpro ?= "21bd4a0a3b0f061e4640dd1011ebc94d122b5e40" |
11 | SRCREV_machine_mpc8315e-rdb ?= "0c781e306559d5e9816e202a60aa2543f4eea39e" | 8 | SRCREV_machine_mpc8315e-rdb ?= "0c781e306559d5e9816e202a60aa2543f4eea39e" |
diff --git a/meta-yocto/recipes-kernel/linux/linux-yocto_3.2.bbappend b/meta-yocto/recipes-kernel/linux/linux-yocto_3.2.bbappend index 815650aec9..dfb019ba2c 100644 --- a/meta-yocto/recipes-kernel/linux/linux-yocto_3.2.bbappend +++ b/meta-yocto/recipes-kernel/linux/linux-yocto_3.2.bbappend | |||
@@ -1,8 +1,3 @@ | |||
1 | KMACHINE_atom-pc = "atom-pc" | ||
2 | KMACHINE_routerstationpro = "routerstationpro" | ||
3 | KMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb" | ||
4 | KMACHINE_beagleboard = "beagleboard" | ||
5 | |||
6 | KBRANCH_atom-pc = "standard/default/common-pc/atom-pc" | 1 | KBRANCH_atom-pc = "standard/default/common-pc/atom-pc" |
7 | KBRANCH_routerstationpro = "standard/default/routerstationpro" | 2 | KBRANCH_routerstationpro = "standard/default/routerstationpro" |
8 | KBRANCH_mpc8315e-rdb = "standard/default/fsl-mpc8315e-rdb" | 3 | KBRANCH_mpc8315e-rdb = "standard/default/fsl-mpc8315e-rdb" |